Recovering bad SSD in the Sophos XG-135w router

This is more of a generic Linux/utilities/hardware question, but it pertains to the use of router.

My Sophos XG-135w was randomly locking up until a few flashes/reboots after I started getting the non-writable partition errors (with ext4 build, not squashfs) or even read errors for /sbin/uci. My guess is that the SSD is going. I bought the router used, so maybe it was used extensively with the Sophos software prior to me getting it.

Anyways, I have the serial cable and my plan is to connect over serial port on the router -- can anyone recommend a Linux distribution/ISO/specific tool which would have serial/CLI tools to test (stress-test?) the SSD and potentially revive it? Is there such a thing as marking bad blocks on SSD?

Even if it's just to confirm that SSD needs to be replaced, I'd prefer to have that done before replacing it.

Are you trying to install OpenWrt on this device?

What model of SSD does it contain? Have you checked whether or not there is updated firmware available for the SSD?

Mosy Linux dists should have smartctl tool installed, and the serial port interface can be added before trying to boot it on the router.

1 Like

Trying to put it back on it, as I think SSD is failing. I'm experiencing a lot of freezes with nothing in the log/htop.

Transcend TS64GSSD370. I have no way of connecting it directly to SATA port anywhere and not sure if the USB enclosure I have will allow for checking/updating firmware.

So I'm looking for something lightweight I could boot the router from which would fit on a 2GB flash-drive. I'm not familiar with Linux SSD health checking tools, that's why I'm asking.

You could try ... OpenWrt? :slight_smile: x86 images also boot from USB.


Looks like it's not SSD, the AMI BIOS is not getting past error 99, I'm afraid it's dead. :frowning:

Before declaring defeat, try replacing the CMOS battery - it might be down to just that (I have an ivy-bridge ASRock board that plays (totally-) dead whenever the CMOS battery fails).

1 Like

Are you saying there are some devices won't boot without the battery? Given how old it is, it's very plausible the button battery has died.

This is actually a thing with some retro computers -- many older Macs, for example, won't boot at all if the battery is missing or dead.

Absolutely worth trying a battery replacement for your device!

I don't have experiences with sophos, but yes, my is completely dead whenever the CMOS battery is empty (and this board uses the battery up quite quickly, in comparison to other boards). No response to the power button at all (the first time this happened, I had already disassembled the system for scraps completely, before giving that a last chance), but I've also seen other weird side effects (sometimes coming up, sometimes not, various BIOS errors) on other boards (e.g. GHM7X-2L4C-VER.C).

Thanks for suggestion, I've replaced the battery with a fresh one from IKEA, sadly same result.

CMOS reset (jumper or keeping the battery out for a few minutes) might be another approach, if that doesn't help, it's getting darker…

Thanks, that was the first thing I've tried when I saw error 99. Didn't help sadly.