Recently created a DUMB AP over LAN Cable. Network is connected. But Internet is inconsistent

reboot the AP, and retry.

then post your /etc/config/wireless and firewall.

WIRELESS

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'
        option cell_density '0'
        option channel '8'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'HOSTXXXX'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option disabled '0'
        option cell_density '0'
        option htmode 'VHT80'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option ssid '5G'
        option key '5GHOSXXX'
- /etc/config/wireless 1/35 2%

FIREWALL

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

nothing that stands out.

what are the clients ?
win ?
phones ?

btw, which ethernet port are you using on the C20 ?

I have connected LAN cable from Main Router to Dumb AP router's LAN Port (Not WAN port according to guide). Clients are :
WIndows 10 Laptop
Android Devices (Tablets Mobile Phones)
Now after rebooting 5Ghz also not working as intended. Now, Both Bands are not working as intended. Except amazon.in is the only new site that both bands are able to open after deleting custom DNS list.

Edit : Openwrt forum opens without issue even if the other sites are failing to load on both bands

interesting.

reset it, and connect it back using the wan port, does everything work then ?

I have never used internet while the port is connected to WAN as I haven't setup the internet via WAN Port. This is the first time I ams setting up DUMB AP which has openwrt software. And I can't make C20 as main router as it is connected to Apartment AP - JIO 4G LTE Router (Indian ISP). So, yea...
I can't make it as my main router as I am away from my home.

it's not going to be the main router, just a router behind a router.

Do you mean turning WAN port into LAN port and WAN port connected to Main AP? The guide you have posted(https://openwrt.org/docs/guide-user/network/wifi/dumbap) is the first thing I have tried to learn how to setup a DUMB AP over LAN cable. It says to use connect LAN cable from Main AP to LAN port of Dumb AP. I would like to try creating Dumb AP over WAN port if you can post any guide regarding that...

I want you to temp convert it back to a router, to see what happens then.

Hmm. Just guide me so that I don't make any mistakes.
I will reset router and connect LAN cable from main AP to wan port of dumb AP.
Then I dunno the configuration of WAN and WAN6 in the interfaces option.

Is there a VPN involved? May be georestriction.

I dunno Dude. I use cloudflare WARP VPN tho. And I ensure that its off everytime I check the internet connection and even closed it from the system tray many times. But I need help regarding setting up my Dumb AP as a normal router - when the LAN cable is connected to WAN port of DUMB AP.

Try removing the openwrt device entirely and then run the same tests. Do you get the same results?

A dumb ap should not cause any of the problems you are describing, so I suspect it is either your computer or your main router/isp.

BTW the router after pinging via ipv4 to openwrt.org it gets with message "bad address"

This is expected if you removed the dns. But it shouldn’t affect the devices that are connecting to the ap.

It is important to determine the source of the problem- please try removing the openwrt device and let us know what happens.

Do you want me to connect my device to main router and check for issues?

Yes. Physically unplug the openwrt device from power so that it cannot possibly influence anything.

You are right. The issue is with the main router i.e, ISP-provided router. But the routers on other floors of my apartment are also from the same ISP but they are working fine. I guess I should contact ISP for solving this issue. I guess I will come back again if anything persists. Thanks for the support guys. @frollic @donbrew @psherman @eduperez Thanks for giving your time to help me fix this. You are the best. Thanks for being patient especially @frollic

1 Like

But its interesting that how only Openwrt forum, Youtube.com and google search work and all other sites doesn't work despite the issue with Main ISP. And WiFi channels of Main ISP show NO internet but when I try to access internet via VPN, its working. I would like to get informed about this, that why VPN giving the internet when its connected to broken internet of main ISP