Receiving Google Captcha

I have setup openwrt on a Linksys box behind my ISPs default box. It looks like this:

     |
 ISP router
     |
 Linksys Box with OpenWrt
    |         |         |
Net 1       Net  2     Net 3

I just used IPv4 internally and disabled IPv6 on all three internal interfaces.
Now when I use the ISP router directly I can use google just normal. Whenever I send a search request from behind the OpenWrt box I get a captcha.

Our systems have detected unusual traffic from your computer network. This page checks to see if it's really you sending the requests, and not a robot.

I tried switching off all devices and restarting the box, waiting for new IPs, used different DNS servers, disconnecting clients individually. All not changing anything. It has been like this for quite some time now and I am starting to wonder if I have misconfigured something.
Also: When switching wifi to the original ISPs box everything works like charm. I just don't understand that because there should be no difference in external IPs.
The only thing I could imagine would be some IPv6 issue but I have really no idea of how IPv6 should be a problem since it is deactivated on all the internal interfaces:

Any help is appreciated.

https://www.webnots.com/fix-im-not-a-robot-captcha-issue-in-google-search/

Enable it back.

is there a good reason for this, like does ipv6 have massive increases in latency or limits on bandwidth? if not, start using ipv6! it's a much better protocol.

one major reason why you are getting the captcha stuff is your ISP might be using ipv4 CGNAT. So basically all their customers appear to come from a small range of IPv4. this means you share the same public IP as some spammers... not good. again ipv6 will solve this

1 Like

No the only reason really is that I don't know much about IPv6 and therefor did not really think I could manage it. But anyway I will try to get it enabled again. :slight_smile: