RE350K with non-ct driver won't start radio0 after reboot

Hello all,

I've been trying to figure this out, but I'm having no luck. I have a TP-Link RE350K that I'm using in my batman-adv setup. I am using it's 5ghz radio as my mesh point. In order to do that, I had to change the driver from -ct to non-ct, otherwise it wouldn't work at all. Since switching the driver, whenever the device restarts for whatever reason (usually by my own design), radio0 won't start automatically. I have to plug-in via ethernet and restart radio0 through Luci or ssh and then it will work.

I've tried searching the forums multiple times for an answer to no avail. I've tried adding /sbin/wifi down radio0 and /sbin/wifi up radio0 to the /etc/rc.local file and that didn't work.

Does anyone have any advice for me to try or a solution? Maybe a cron job/script?

While debugging, start simple and methodically, in baby-steps:

  • does the default image (ath10k-ct) work
    • can you scan
    • does an AP interface come up and work
  • next step would be replacing ath10k-ct with ath10k and their corresponding firmware
    • can you scan
    • does an AP interface come up and work

If all of these basics work, you have successfully managed to replace ath10k-ct with ath10k and should see the corresponding (different) module load messages in dmesg. Only now it makes sense to look into mesh/ batman-adv specific issues.

Replacing ath10k-ct with ath10k is a tad complex, as it involves replacing several packages (basically-) in lockstep (and still retaining the board files in place), so always ensure first that this part succeeded, before spending time on more complex setups.

Being able to scan on a radio, albeit this being a rather basic test, is 90% of a confirmation that it is functional, so always test this first.

Thank you.

I used to use the 2.4ghz radio for the mesh point and 802.11s worked good having the -ct drivers. I then switched all my devices to use their 5ghz radios for the mesh backhaul. This was no problem for some of my devices, but the Archer C7’s and the RE350K’s use of Qualcomm Atheros with the -ct drivers made it so 802.11s did not work for their 5ghz radios. That’s when I troubleshooted and found people had experienced similar results and the “fix” for that was replacing the -ct driver packages with the non-ct driver packages.

The devices and radios work fine, that is, after having to restart their 5ghz radios manually upon any reboots. That’s the bug I’m experiencing since changing to non-ct drivers. I’ve since retired my Archer C7’s for the Lyra MAP-AC2200’s. But the RE350K’s are still being used. Any time the RE350K has to reboot, the 5ghz radio doesn’t start automatically… and it’s annoying lol. Once I restart the radio after a reboot, the device works great.

That is correct, ath10k-ct does not support meshing on wave1 radios (a bit careful though, QCA9558 is the SOC and 2.4 GHz ath9k radio, QCA9880-BR4A as in the archer c7 would be a wave1 radio, QCA9882 as in the re350k would be a wave2 radio), while mainline's ath10k can do meshing on wave1 and wave2.

Ahh, I see. My mistake on which SOC it was. But I digress. I’m just looking for a way to reboot the device without manually having to restart the 5ghz radio afterward.