RB2011 SFP port with VDSL2 SFP not working

i have the ALLNET ALL4781-VDSL2-SFP and want to use it as WAN port.

when the sfp is plugged in the modem syncs correctly but the link status in openwrt stays down (only tx packets, no rx packets).


but as i understand how the modem works the link should come up the moment the spf gets plugged in, regardless off an existing synced line.

where to start investigating?

1 Like

Maybe like that


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix ‘XXXXXXX’

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'p2'
	list ports 'p3'
	list ports 'p4'
	list ports 'p5'
	list ports 'p6'
	list ports 'p7'
	list ports 'p8'
	list ports 'sfp'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'sfp'

config device
	option type '8021q'
	option ifname 'sfp'
	option vid '832'
	option name 'sfp.832'

config interface 'wan'
	option proto 'dhcp'
	option device 'sfp.832'
	option broadcast '1'
	option vendorid 'sagem'
	option reqopts '1 15 28 51 58 59 90'
	option sendopts ‘XXXXX’

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'sfp.832'
	option reqaddress 'none'
	option reqprefix 'auto'
	option defaultreqopts '0'
	option sendopts ‘XXXXXXX’
	option noclientfqdn '1'
	option noacceptreconfig '1'

I think not long of success like you :slight_smile:
I has similair but rb5009

do you also use a VDSL SFP? have you got it successfully running?

1 Like

Yes i'm use vdsl2 sfp but he doesnt work for the moment

What is your etc/config/network ??

The all4781 needs to be set to a fixed linkspeed, to work.

ethtool -s sfp speed 1000 duplex full autoneg off

This should do the trick.

2 Likes

thx 4 the hint.

will test an report back.

tested and: IT WORKS! :+1: :+1: :+1: