Rationale behind network configuration

Whilst I was looking upon openwrt typical dsl router confiuration:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd2:a40d:d919::/48'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '00:20:da:86:23:75'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option tone 'auto'
	option firmware '/lib/firmware/vr9-B-dsl.bin' 

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ip4table '1'

config interface 'wan'
	option device 'dsl0.835'
	option proto 'pppoe'
	option username 'guest@adsl.gr'
	option password '******'
	option ipv6 'none'
	option keepalive '10'
	option mtu '1492'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option peerdns '0'

config interface 'voip'
	option device 'dsl0.837'
	option proto 'dhcp'
	option defaultroute '0'
	option ip4table '2'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

Tried to understand the logic on it/distinguish a pattern compared to classical debian config:

    auto eth0
    allow-hotplug eth0
    iface eth0 inet dhcp

Of via setting a manual IP:

    auto eth0
    iface eth0 inet static
        address 192.0.2.7/24
        gateway 192.0.2.254

It really confuces me. I mean on typicval debian just did:

ifconfig -a

and then according to output could tell per interface seen what to do. On open wrt I have no straightforward comparison between ifconfig outpout and networking configuation. Is there some mnemonic way for a given configuration what to do?

Well in openwrt we use uci commands to control the system rather than ifconfig.

Uci output is effectively the same as the openwrt config files.