Raspi 4 single port vlan

I am using single port Raspi 4 going to smart switch.. current configuration works great except I cannot create a guest vlan..which interface should I use to create a vlan?

raspi2

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdad:056b:e9d1::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'WAN'
        option proto 'dhcp'
        option device 'eth0.2'
        option hostname '*'

config interface 'WAN6'
        option proto 'dhcpv6'
        option device 'eth0.2'
        option reqaddress 'try'
        option reqprefix 'auto'

I would remove that LAN as it is now and make a unique VLAN for WAN and LAN and Guest connected to eth0 bridge.
And then make interfaces for these VLAN and then config the firewall to put the VLAN where they belong.

At the custom field at the bottom of the drop down list type eth0.3 and press enter.