Raspberry Pi Zero W not allowing connections to WiFi

I am setting a Raspberry Pi Zero W to be a repeater. I have successfully installed OpenWRT and enabled WiFi.
I then went to the LuCA interface and tried to connect to a WiFi network. When I tried on the LuCA interface, it disconnected the WiFi and displayed "Can't connect to this network" for about 30 seconds when I tried to connect to it, afterwords it connects successfully. I tried running the commands LuCA was trying to apply manually followed by uci commit and rebooting.
Now, I can't connect to the WiFi without getting "Can't connect to this network". I've tested on two separate computers with one running Linux and one running Windows.

Why is this happening?

This is probably still valid Raspberry Pi Zero W AP+STA mode - #2 by lleachii

Can I install the non-FOSS drivers on OpenWRT?

you could try to manually replace the files, yes ....

but the performance will be pretty bad anyway.

Why would the performance be bad? I thought RPis had way more processing power then most routers that OpenWRT works well on...

CPU performance <> wifi performance.

because the antenna is a joke.

Is the RPi 3's antenna any better? And does it have support for simultaneous AP/STA?

perhaps, but not much ....

no idea, it's Broadcom, so I wouldn't get my hopes up.

Okay, I guess I'll try some other WiFi projects for my Pi and maybe buy a cheap router instead. Thanks for your help.

This is difficult/impossible on most one radio WiFi routers. Until it has connected as a client to the upstream network, the AP network is not available.

I suspect, but have never seen this written, that this is likely because the radio is scanning for the upstream network over multiple channels, and only when it has settled on a channel will the AP channel be stable.

Simultaneous AP/STA means a WiFi extender, right? If so, I got this working on another router I have, without any special setup.

WiFi extender does that yes.