Raspberry PI imager error

Input file is not a valid disk image.
File size xxx bytes is not a multiple of 512 bytes.

I am not sure how this tool works, but did you verify the sha256sum after you downloaded the image for integrity check? Did you un-gzip the image?

Oh, ya.

I should have said, yes .img file was unziped from archive, no errors during unzipping.

Best regards, Vit

If you unzipped the file before uploading to the pi imager try leaving it zipped and letting the imager unzip it (that's how I've used the imager and haven't had this error with 21.02.0).

1 Like

Well, first step passed - imager kind of writes image file (.gzip file)...

But, this time there is another issue - validation fails and indeed RaspberryPI device is not loading at all - complains abt - no valid bootable info available...basically card image is corrupted.

1 Like

I resorted to using Rufus on Windows.

Are you using the imager to format the card? if so try formatting it on your os first (windows/mac/linux), i had problems too when trying to use the imager to format a card that had the squashfs image. Just tried 21.02.0, formatted with gparted, flashed with imager and it worked ok -

Hey, Just to give a short Feedback for potential other people who face that Problem in the future. I had the same verifying issue with the Raspberry Pi Imager in combination with OpenWrt (it works with other distros just fine). Using Rufus (or probably every other imager) solved the problem for me.