Raspberry pi 4 stuck at first boot

Hi all!

After flashing several times my SD card I'm still unable to make the pi boot, Attached picture show the Exact point where is getting stuck.

Ping is not responding and I believe it's because initial setup isn't complete.

Any suggestions will be appreciated.


Was the SD card empty (or was it used before)? Have you completely wiped it before writing the image? Which tool are you using to write the image?

Yes the SD card was wiped several times, erased using raspberry pi imager utility and from windows.

To write the image I use raspberry pi imager and Rufus, I even deleted and downloaded the image several times and tried to connect from 3 different computers.

Last night I managed to log in, edited network config file and was looking good but I had to wipe the image again after facing errors configuring the wireless adapter.

Tried to unplug and plug the network cable and you can see the results here

I would try another SD just in case.

1 Like

I think it actually has booted since it has the port up and ready (which is the last work done in the boot process) and it is waiting for you to do something.
Have you pushed the Enter key when the “boot stops”, then I think you will see the OpenWRT logo?


Sorry for reply this late.

Like flygarn12 said the Pi actually booted and after hitting enter the logo appeared, checking the config files i found OpenWrt was configured with the IP that I set up the first time and not the default one but now comes the creepy thing, the SD card was erased, formatted and reimaged at least 6 times after the first set up so how in the world is it possible that it kept those settings is an Xfile.

The only thing that i can think of is that the flash card is corrupted or about to die and it entered in read only mode because i didn't managed to change any settings after the last boot.

Ended Up flashing a new card and OpenWRT is now running on my PI.

Thanks for the help!

It can be a broken card, but with a SanDisk card that is kind of one in a trillion cards.
As far as I know both rufus and BalenaEthcer verify the written code after writing to the flash.

You could try encrypt the card and after that format it to shake it up.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.