Raspberry Pi 4 install openwrt proper IMG w/LuCi

Where to go for proper images: https://downloads.openwrt.org/snapshots/targets/bcm27xx/bcm2711/
Still not sure if rpi-4-ext4-factory.img actually works at this location.
Leaving this thread open and if anyone wants to test this image download and check if LuCI installs properly I can update OP to help others.
Can confirm LuCi installer is working on rpi-4-ext4-sysupgrade.img.gz

These links are on this page: https://downloads.openwrt.org/snapshots/targets/brcm2708/bcm2711/

This IMG is deprecated as LuCI install package is unreachable: cant remember link destination.
sha256sum: 4dbd1751fc7dba14984fbcebb4d961771b5f259ac1414baaf1efd0f4c4a1452a
13402.4 KB Fri Feb 14 01:49:43 2020

To install LuCI use the following(the second on list) rpi-4-ext4-sysupgrade.img.gz

if someone else wants to report, be my guest, searched the bug page and didnt find it. Dont know how to report bugs, dont have the time.

A instruction for initially setting up RPi 4 with internet access:
DISCONNECT from your home(wifi) network from your computer. if you know your ip network is not 192.168.1.x then dont bother disconnecting.
connect to pi with ethernet
Pi default IP is (kind of dumb in my option)
assign yourself 192.168.1.xx
ssh to Pi using putty or whatever you want. user:root / no password needed
got to vi /etc/config/network press a to start editing
change option proto 'static' TO option proto 'dhcp'
press Esc then : type wq (this will save changes) (to quite without changes q!)
RECONNECT to wifi network
then on your computer under network adapters, go to properties of the wifi connection and share internet connection with ethernet
then open CMD type arp -a
check for an address(in windows) that starts with 192.168.137.x
You have to enter it a few times until you see an address (not the
Use that IP to SSH into the Pi, you will then have internet on the Pi to add any packages and setup it all up.
Once you download and install everything you need, especially LuCi opkg install lucu for GUI and quick changes like setting up DHCP when you are ready to turn over controls of routing to Pi.
In Web Browser, G o to IP you used to SSH then under Interfaces tab click Edit to change to a static address and enable DHCP is you like.

Not a bug, bcm2708 target has changed to bcm27xx https://downloads.openwrt.org/snapshots/targets/bcm27xx/bcm2711/

1 Like

See I pulled you out of retirement for a reply ha

1 Like

I followed your instructions; can't access ssh second time with The set password is not accepted. No failure possible due to copy/paste second try after reflashing the image.
Luckily the pi can be accessed with monitor and keyboard, so I will try that now.

1 Like