Raspberry Pi 3 B + OpenWrt = Permanent Rainbow Mode

Hello guys,

I would love to use OpenWRT on my Raspberry Pi 3 B. It is not the PLUS edition but reading the documentation it indicates that the latest (19.07) version should work just fine. I used different methods to install it on my sd card: dd on macOs and Etcher on Windows. If I boot the RPI it's stuck on the rainbow screen. I tried different versions and tbh I can not keep track of all of the versions I already used. There were some versions where there was no screen output at all.

Am I misunderstanding something? I don't understand what I am doing wrong. I can boot Raspbian just fine.

Bonus question: Can I even use this as a router? I got a wifi usb dongle with access point support.

I don't recall doing anything much different than flashing the ext4 image with dd in linux and expanding the partition.
You are using the factory image, right?
Mine is 4B though, but should not make a difference.
You can use it as a router. Multiple vlans on the single ethernet, or usb2eth adapter, or eth+wifi.

The rainbow screen means the firmware on the RPi cannot boot from the card. Perhaps the card is damaged, or you are using the wrong file, or are installing it incorrectly.

Can you post the exact file and procedure you are following?

@trendy @eduperez thanks for your quick replies. I used the image @trendy linked alongside https://www.balena.io/etcher/ -- I tried it using dd on unix as well. I tried the same procedure with Raspbian and it works fine so I would assume that the hardware is working fine?

The detailed procedure was:

  1. Downloading image
  2. Flashing image
  3. Booting Pi

I tried to unzip the image as well (since it's a .gz file) and flashed the image directly - Seems to make no difference though.

I don't really see anything I am missing here. Raspbian works fine as well and I am out of ideas... Is there something like a console output when the rainbow screen shows? I read it means that the kernel is not loading so I assume there's no output anywhere

Ok just realized it's not a RPI 3, it's just a RPI (at least that's what's written on the board) but the OpenWRT documentation states that the current release should be fine. I got this one: https://www.raspberrypi.org/products/raspberry-pi-1-model-b-plus/

So I am just dumb af, I own a RPI 1 B+ so this is the correct version: http://downloads.openwrt.org/releases/19.07.2/targets/brcm2708/bcm2708/openwrt-19.07.2-brcm2708-bcm2708-rpi-ext4-factory.img.gz


Okay so I guess now I just need to figure out how to use the Pi as a access point with my Wi-Fi adapter

You got it working with this image, no rainbow screen any more?