Raspberry pi 3 B+ no wifi

Hi
I have installed OpenWrt for raspberry pi 3 B+ from the development builds images,configured and installed luci interface, however I can't get wifi up,any advise or guidance will be greatly appreciated

 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r8165-3fa7e62
 -----------------------------------------------------
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd0:8347:7780::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1'
        option force_link '1'

root@OpenWrt:~# cat /etc/config/wireless
root@OpenWrt:~# uci show wireless
root@OpenWrt:~# wifi
root@OpenWrt:~# wifi up
root@OpenWrt:~# wifi status
{

}
root@OpenWrt:~# iw reg get
global
country 00: DFS-UNSET
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
        (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
        (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
        (5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
        (57240 - 63720 @ 2160), (N/A, 0), (N/A)

root@OpenWrt:~# rm -f /etc/config/wireless
root@OpenWrt:~# wifi
root@OpenWrt:~# wifi status
{

}
root@OpenWrt:~# 

dmesg

root@OpenWrt:~# dmesg
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.9.129 (buildbot@crazyhorse) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r8123-dee8804) ) #0 SMP Wed Sep 26 22:22:13 2018
[    0.000000] Boot CPU: AArch64 Processor [410fd034]
[    0.000000] cma: Reserved 16 MiB at 0x000000003a400000
[    0.000000] On node 0 totalpages: 242688
[    0.000000]   DMA zone: 3792 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 242688 pages, LIFO batch:31
[    0.000000] percpu: Embedded 20 pages/cpu @ffffffc03a386000 s44056 r8192 d29672 u81920
[    0.000000] pcpu-alloc: s44056 r8192 d29672 u81920 alloc=20*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 
[    0.000000] Detected VIPT I-cache on CPU0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 238896
[    0.000000] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 kgdboc=ttyS0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
[    0.000000] PID hash table entries: 4096 (order: 3, 32768 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
[    0.000000] Memory: 928864K/970752K available (4606K kernel code, 278K rwdata, 1448K rodata, 320K init, 325K bss, 25504K reserved, 16384K cma-reserved)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     modules : 0xffffff8000000000 - 0xffffff8008000000   (   128 MB)
[    0.000000]     vmalloc : 0xffffff8008000000 - 0xffffffbebfff0000   (   250 GB)
[    0.000000]       .text : 0xffffff8008080000 - 0xffffff8008500000   (  4608 KB)
[    0.000000]     .rodata : 0xffffff8008500000 - 0xffffff8008670000   (  1472 KB)
[    0.000000]       .init : 0xffffff8008670000 - 0xffffff80086c0000   (   320 KB)
[    0.000000]       .data : 0xffffff80086c0000 - 0xffffff8008705808   (   279 KB)
[    0.000000]        .bss : 0xffffff8008705808 - 0xffffff8008756cf4   (   326 KB)
[    0.000000]     fixed   : 0xffffffbefe7fb000 - 0xffffffbefec00000   (  4116 KB)
[    0.000000]     PCI I/O : 0xffffffbefee00000 - 0xffffffbeffe00000   (    16 MB)
[    0.000000]     vmemmap : 0xffffffbf00000000 - 0xffffffc000000000   (     4 GB maximum)
[    0.000000]               0xffffffbf00000000 - 0xffffffbf00ed0000   (    14 MB actual)
[    0.000000]     memory  : 0xffffffc000000000 - 0xffffffc03b400000   (   948 MB)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000]  CONFIG_RCU_FANOUT set to non-default value of 32
[    0.000000] NR_IRQS:64 nr_irqs:64 0
[    0.000000] arm_arch_timer: Architected cp15 timer(s) running at 19.20MHz (phys).
[    0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x46d987e47, max_idle_ns: 440795202767 ns
[    0.000006] sched_clock: 56 bits at 19MHz, resolution 52ns, wraps every 4398046511078ns
[    0.000206] Console: colour dummy device 80x25
[    0.000915] console [tty1] enabled
[    0.000952] Calibrating delay loop (skipped), value calculated using timer frequency.. 38.40 BogoMIPS (lpj=192000)
[    0.000998] pid_max: default: 32768 minimum: 301
[    0.001115] Mount-cache hash table entries: 2048 (order: 2, 16384 bytes)
[    0.001145] Mountpoint-cache hash table entries: 2048 (order: 2, 16384 bytes)
[    0.002032] ASID allocator initialised with 32768 entries
[    0.003457] Detected VIPT I-cache on CPU1
[    0.003506] CPU1: Booted secondary processor [410fd034]
[    0.003960] Detected VIPT I-cache on CPU2
[    0.003993] CPU2: Booted secondary processor [410fd034]
[    0.004431] Detected VIPT I-cache on CPU3
[    0.004464] CPU3: Booted secondary processor [410fd034]
[    0.004538] Brought up 4 CPUs
[    0.004675] SMP: Total of 4 processors activated.
[    0.004702] CPU features: detected feature: 32-bit EL0 Support
[    0.004727] CPU features: detected feature: Kernel page table isolation (KPTI)
[    0.006147] CPU: All CPU(s) started at EL2
[    0.006186] alternatives: patching kernel code
[    0.017819] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.017881] futex hash table entries: 1024 (order: 5, 131072 bytes)
[    0.018644] pinctrl core: initialized pinctrl subsystem
[    0.019616] NET: Registered protocol family 16
[    0.049908] cpuidle: using governor ladder
[    0.079927] cpuidle: using governor menu
[    0.080146] vdso: 2 pages (1 code @ ffffff8008505000, 1 data @ ffffff80086c4000)
[    0.081081] DMA: preallocated 256 KiB pool for atomic allocations
[    0.081160] Serial: AMBA PL011 UART driver
[    0.084453] bcm2835-mbox 3f00b880.mailbox: mailbox enabled
[    0.084904] uart-pl011 3f201000.serial: could not find pctldev for node /soc/gpio@7e200000/uart0_pins, deferring probe
[    0.140832] bcm2835-dma 3f007000.dma: DMA legacy API manager at ffffff800804f000, dmachans=0x1
[    0.142859] SCSI subsystem initialized
[    0.143134] usbcore: registered new interface driver usbfs
[    0.143220] usbcore: registered new interface driver hub
[    0.143298] usbcore: registered new device driver usb
[    0.150030] raspberrypi-firmware soc:firmware: Attached to firmware from 2018-05-11 10:20
[    0.151152] clocksource: Switched to clocksource arch_sys_counter
[    0.158011] NET: Registered protocol family 2
[    0.158628] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[    0.158760] TCP bind hash table entries: 8192 (order: 5, 131072 bytes)
[    0.158970] TCP: Hash tables configured (established 8192 bind 8192)
[    0.159139] UDP hash table entries: 512 (order: 2, 16384 bytes)
[    0.159200] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[    0.159405] NET: Registered protocol family 1
[    0.160890] Crashlog allocated RAM at address 0x3f00000
[    0.161226] workingset: timestamp_bits=62 max_order=18 bucket_order=0
[    0.169434] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.170912] io scheduler noop registered
[    0.170939] io scheduler deadline registered
[    0.171107] io scheduler cfq registered (default)
[    0.175466] BCM2708FB: allocated DMA memory fa440000
[    0.175514] BCM2708FB: allocated DMA channel 0 @ ffffff800804f000
[    0.182596] Console: switching to colour frame buffer device 82x26
[    0.186947] Serial: 8250/16550 driver, 1 ports, IRQ sharing enabled
[    0.189439] console [ttyS0] disabled
[    0.191203] 3f215040.serial: ttyS0 at MMIO 0x0 (irq = 61, base_baud = 31250000) is a 16550
[    0.764855] console [ttyS0] enabled
[    0.770703] vc-mem: phys_addr:0x00000000 mem_base=0x3ec00000 mem_size:0x40000000(1024 MiB)
[    0.782833] Unable to detect cache hierarchy for CPU 0
[    0.801008] brd: module loaded
[    0.812338] loop: module loaded
[    0.817571] libphy: Fixed MDIO Bus: probed
[    0.823476] usbcore: registered new interface driver lan78xx
[    0.830947] usbcore: registered new interface driver smsc95xx
[    0.838400] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[    1.073834] Core Release: 2.80a
[    1.078569] Setting default values for core params
[    1.085055] Finished setting default values for core params
[    1.292652] Using Buffer DMA mode
[    1.297630] Periodic Transfer Interrupt Enhancement - disabled
[    1.305246] Multiprocessor Interrupt Enhancement - disabled
[    1.312592] OTG VER PARAM: 0, OTG VER FLAG: 0
[    1.318663] Dedicated Tx FIFOs mode
[    1.324296] WARN::dwc_otg_hcd_init:1053: FIQ DMA bounce buffers: virt = 0x087e4000 dma = 0xfa454000 len=9024
[    1.337581] FIQ FSM acceleration enabled for :
[    1.337581] Non-periodic Split Transactions
[    1.337581] Periodic Split Transactions
[    1.337581] High-Speed Isochronous Endpoints
[    1.337581] Interrupt/Control Split Transaction hack enabled
[    1.367945] dwc_otg: Microframe scheduler enabled
[    1.368015] WARN::hcd_init_fiq:486: MPHI regs_base at 0x08078000
[    1.375750] dwc_otg 3f980000.usb: DWC OTG Controller
[    1.382404] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
[    1.391471] dwc_otg 3f980000.usb: irq 15, io mem 0x00000000
[    1.398790] Init: Port Power? op_state=1
[    1.404372] Init: Power Port (0)
[    1.409377] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.417919] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.426893] usb usb1: Product: DWC OTG Controller
[    1.433282] usb usb1: Manufacturer: Linux 4.9.129 dwc_otg_hcd
[    1.440716] usb usb1: SerialNumber: 3f980000.usb
[    1.447521] hub 1-0:1.0: USB hub found
[    1.452908] hub 1-0:1.0: 1 port detected
[    1.458903] dwc_otg: FIQ enabled
[    1.458906] dwc_otg: NAK holdoff enabled
[    1.458910] dwc_otg: FIQ split-transaction FSM enabled
[    1.458920] Module dwc_common_port init
[    1.459081] usbcore: registered new interface driver uas
[    1.466097] usbcore: registered new interface driver usb-storage
[    1.473759] mousedev: PS/2 mouse device common for all mice
[    1.481269] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer
[    1.489975] bcm2835-cpufreq: min=600000 max=1400000
[    1.496829] sdhci: Secure Digital Host Controller Interface driver
[    1.504691] sdhci: Copyright(c) Pierre Ossman
[    1.511041] sdhost: log_buf @ ffffff800807e000 (fa453000)
[    1.591147] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
[    1.599385] mmc-bcm2835 3f300000.mmc: mmc_debug:0 mmc_debug2:0
[    1.605982] mmc-bcm2835 3f300000.mmc: DMA channel allocated
[    1.671195] Indeed it is in host mode hprt0 = 00021501
[    1.691173] sdhci-pltfm: SDHCI platform and OF driver helper
[    1.699964] NET: Registered protocol family 10
[    1.706762] NET: Registered protocol family 17
[    1.711945] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.726453] 8021q: 802.1Q VLAN Support v1.8
[    1.737045] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 72, base_baud = 0) is a PL011 rev2
[    1.747816] of_cfs_init
[    1.751075] of_cfs_init: OK
[    1.755100] Waiting for root device /dev/mmcblk0p2...
[    1.769496] mmc0: host does not support reading read-only switch, assuming write-enable
[    1.780275] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
[    1.787656] mmc0: new high speed SDHC card at address e624
[    1.794285] mmcblk0: mmc0:e624 SU04G 3.69 GiB
[    1.799668] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[    1.807456] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[    1.807503] random: fast init done
[    1.817964]  mmcblk0: p1 p2
[    1.824273] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
[    1.871152] usb 1-1: new high-speed USB device number 2 using dwc_otg
[    1.878552] Indeed it is in host mode hprt0 = 00001101
[    1.885265] VFS: Mounted root (squashfs filesystem) readonly on device 179:2.
[    1.893529] Freeing unused kernel memory: 320K
[    1.911956] mmc1: new high speed SDIO card at address 0001
[    2.069847] init: Console is alive
[    2.074174] init: - watchdog -
[    2.124382] usb 1-1: New USB device found, idVendor=0424, idProduct=2514
[    2.131985] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.142483] hub 1-1:1.0: USB hub found
[    2.169323] hub 1-1:1.0: 4 ports detected
[    2.352238] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    2.417346] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    2.431201] init: - preinit -
[    2.491201] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[    2.621523] usb 1-1.1: New USB device found, idVendor=0424, idProduct=2514
[    2.630227] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.640196] hub 1-1.1:1.0: USB hub found
[    2.646030] hub 1-1.1:1.0: 3 ports detected
[    2.690239] random: procd: uninitialized urandom read (4 bytes read)
[    2.751230] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[    2.894164] usb 1-1.2: New USB device found, idVendor=0b95, idProduct=7720
[    2.903014] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.912260] usb 1-1.2: Product: AX88x72A
[    2.917986] usb 1-1.2: Manufacturer: ASIX Elec. Corp.
[    2.924905] usb 1-1.2: SerialNumber: 0003AE
[    3.125170] random: crng init done
[    3.401171] usb 1-1.1.1: new high-speed USB device number 5 using dwc_otg
[    3.531617] usb 1-1.1.1: New USB device found, idVendor=0424, idProduct=7800
[    3.540588] usb 1-1.1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.828919] libphy: lan78xx-mdiobus: probed
[    7.275896] mount_root: switching to f2fs overlay
[    7.334631] urandom-seed: Seeding with /etc/urandom.seed
[    7.435088] procd: - early -
[    7.439794] procd: - watchdog -
[    8.105169] procd: - watchdog -
[    8.110186] procd: - ubus -
[    8.166029] procd: - init -
[    8.366627] kmodloader: loading kernel modules from /etc/modules.d/*
[    8.390316] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    8.403549] hidraw: raw HID events driver (C) Jiri Kosina
[    8.869970] asix 1-1.2:1.0 eth1: register 'asix' at usb-3f980000.usb-1.2, ASIX AX88772 USB 2.0 Ethernet, 8c:ae:4c:f9:e0:1c
[    8.884512] usbcore: registered new interface driver asix
[    8.892753] usbcore: registered new interface driver ax88179_178a
[    8.902647] Loading modules backported from Linux version v4.19-rc5-0-g6bf4ca7fbc85
[    8.913576] Backport generated by backports.git v4.19-rc5-1-0-g05571dcd
[    8.924383] ip_tables: (C) 2000-2006 Netfilter Core Team
[    8.937493] nf_conntrack version 0.5.0 (7680 buckets, 30720 max)
[    8.964605] usbcore: registered new interface driver usbhid
[    8.971964] usbhid: USB HID core driver
[    8.983451] xt_time: kernel timezone is -0000
[    9.004297] PPP generic driver version 2.4.2
[    9.011239] NET: Registered protocol family 24
[    9.027704] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    9.294236] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    9.313015] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar  1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4
[    9.332597] ------------[ cut here ]------------
[    9.338161] WARNING: CPU: 0 PID: 112 at backports-4.19-rc5-1/net/wireless/core.c:736 wiphy_register+0x23c/0x8c0 [cfg80211]
[    9.351073] Modules linked in: brcmfmac(+) pppox ppp_generic nf_conntrack_ipv6 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT usbhid slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables hid_generic crc_ccitt compat brcmutil ax88179_178a asix hid evdev ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables snd_pcm_dmaengine snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd soundcore nls_utf8 vfat fat nls_iso8859_1 nls_cp437
[    9.431880] 
[    9.435382] CPU: 0 PID: 112 Comm: kworker/0:2 Not tainted 4.9.129 #0
[    9.442866] Hardware name: Raspberry Pi 3 Model B Plus Rev 1.3 (DT)
[    9.450261] Workqueue: events request_firmware_work_func
[    9.456652] task: ffffffc037cb0a80 task.stack: ffffffc038370000
[    9.463649] PC is at wiphy_register+0x23c/0x8c0 [cfg80211]
[    9.470208] LR is at brcmf_cfg80211_attach+0x938/0x1088 [brcmfmac]
[    9.477448] pc : [<ffffff800069457c>] lr : [<ffffff800070b150>] pstate: 40000145
[    9.486885] sp : ffffffc038373b10
[    9.491178] x29: ffffffc038373b10 x28: ffffff8000722848 
[    9.497495] x27: ffffffc0383fa380 x26: 0000000000000002 
[    9.503778] x25: ffffffc03746e000 x24: ffffffc038373c20 
[    9.510026] x23: ffffff8008732a20 x22: ffffffc03746d900 
[    9.516248] x21: ffffffc0383fa39c x20: ffffffc03778bf00 
[    9.522436] x19: ffffffc03771e000 x18: 0000000000000000 
[    9.528597] x17: ffffff8008530144 x16: ffffff8008530144 
[    9.534733] x15: ffffff8008530144 x14: 000e09b400000000 
[    9.540826] x13: 0000000000000000 x12: 0000000000000000 
[    9.546896] x11: 0000000000000000 x10: 0000000000000000 
[    9.552921] x9 : 0000000000000000 x8 : 0000000000000000 
[    9.558902] x7 : 0000000000000000 x6 : ffffffc037b22b80 
[    9.564862] x5 : 0000000000000000 x4 : 0000000000000000 
[    9.570799] x3 : ffffff8000707c28 x2 : ffffffc03778cf8a 
[    9.576723] x1 : 000000000000070e x0 : ffffffc03778c300 
[    9.582629] 
[    9.584618] ---[ end trace 27b811a9c2eac30b ]---
[    9.589796] Call trace:
[    9.592734] Exception stack(0xffffffc038373930 to 0xffffffc038373a60)
[    9.599746] 3920:                                   ffffffc03771e000 0000007fffffffff
[    9.608665] 3940: ffffffc038373b10 ffffff800069457c 0000000040000145 000000000000003d
[    9.617677] 3960: ffffffc0383739c0 000000018020001f ffffffc0383fa880 000000018020001f
[    9.626827] 3980: ffffffc038373990 ffffff800813acf4 ffffffc0383739c0 ffffff800813c318
[    9.636098] 39a0: ffffffc0383fa880 ffffffc037760054 ffffffc0383739e0 ffffff8008111054
[    9.645493] 39c0: 0000000000000003 ffffffc0383fa380 ffffffc0383739e0 ffffff8008123754
[    9.655048] 39e0: ffffffc03778c300 000000000000070e ffffffc03778cf8a ffffff8000707c28
[    9.664739] 3a00: 0000000000000000 0000000000000000 ffffffc037b22b80 0000000000000000
[    9.674555] 3a20: 0000000000000000 0000000000000000 0000000000000000 0000000000000000
[    9.684444] 3a40: 0000000000000000 0000000000000000 000e09b400000000 ffffff8008530144
[    9.694451] [<ffffff800069457c>] wiphy_register+0x23c/0x8c0 [cfg80211]
[    9.702137] [<ffffff800070b150>] brcmf_cfg80211_attach+0x938/0x1088 [brcmfmac]
[    9.710537] [<ffffff80007138e8>] brcmf_attach+0x1b8/0xec0 [brcmfmac]
[    9.718032] [<ffffff800071bf9c>] brcmf_sdio_wd_timer+0x4c4/0x2918 [brcmfmac]
[    9.726216] [<ffffff80007145b8>] brcmf_attach+0xe88/0xec0 [brcmfmac]
[    9.733658] [<ffffff800831a3dc>] request_firmware_work_func+0x34/0x60
[    9.741178] [<ffffff80080a9c18>] process_one_work+0x208/0x350
[    9.747953] [<ffffff80080a9ffc>] worker_thread+0x29c/0x4a8
[    9.754444] [<ffffff80080af8bc>] kthread+0xdc/0xf0
[    9.760202] [<ffffff8008082d30>] ret_from_fork+0x10/0x20
[    9.766506] brcmfmac: brcmf_cfg80211_attach: Could not register wiphy device (-22)
[    9.775938] brcmfmac: brcmf_bus_started: failed: -12
[    9.781829] brcmfmac: brcmf_attach: dongle is not responding: err=-12
[    9.841346] brcmfmac: brcmf_sdio_firmware_callback: brcmf_attach failed
[   14.071488] usbcore: registered new interface driver brcmfmac
[   14.081323] kmodloader: done loading kernel modules from /etc/modules.d/*
[   17.163839] lan78xx 1-1.1.1:1.0 eth0: kevent 4 may have been dropped
[   17.174112] br-lan: port 1(eth0) entered blocking state
[   17.180237] br-lan: port 1(eth0) entered disabled state
[   17.186514] device eth0 entered promiscuous mode
[   17.193332] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   17.206028] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   17.338615] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   17.348678] asix 1-1.2:1.0 eth1: link up, 100Mbps, full-duplex, lpa 0xC1E1
[   20.541262] br-lan: port 1(eth0) entered blocking state
[   20.548281] br-lan: port 1(eth0) entered forwarding state
[   20.555602] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   49.018254] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[   49.030386] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[   49.044855] cpufreq: __target_index: Failed to change cpu frequency: -22
[   49.375356] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[   49.387731] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[   49.402405] cpufreq: __target_index: Failed to change cpu frequency: -22
[   60.386248] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[   60.398888] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[   60.413941] cpufreq: __target_index: Failed to change cpu frequency: -22
[   66.948766] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[   66.961883] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[   66.977312] cpufreq: __target_index: Failed to change cpu frequency: -22
[   91.381208] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[   91.394590] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[   91.410259] cpufreq: __target_index: Failed to change cpu frequency: -22
[   97.856170] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[   97.869526] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[   97.885044] cpufreq: __target_index: Failed to change cpu frequency: -22
[  158.816851] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[  158.830206] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[  158.845787] cpufreq: __target_index: Failed to change cpu frequency: -22
[  159.172248] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[  159.185618] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[  159.201245] cpufreq: __target_index: Failed to change cpu frequency: -22
[  159.529313] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[  159.542679] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[  159.558207] cpufreq: __target_index: Failed to change cpu frequency: -22
[  499.311196] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[  499.324516] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[  499.340050] cpufreq: __target_index: Failed to change cpu frequency: -22
[  543.111195] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
[  543.124524] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000)
[  543.140055] cpufreq: __target_index: Failed to change cpu frequency: -22
root@OpenWrt:~# 

Hi, did you get wifi up now?

You need to set the country code to start the WiFi, I have the same issue but cannot work out how to persist it.

Running OpenWrt SNAPSHOT, r8639-99e2121, now the WiFi is properly detected and intialized, but it is non-functional as an AccessPoint (to use the RaspPi3B+ as an WiFi AP).

The official image, 18.06.01, is still not booting on RaspPi3B+ although claimed otherwise. It is somehow more than frustrating.

@SB211 I'm trying today SNAPSHOT r8663-1286c55 and WiFi works on STA and AP mode, as is mention above if you not set country code wifi will not work. only issue found so far is when I connect an USB to ethernet adapter as WAN system log get flooded with this error:

Sat Dec  8 13:57:42 2018 kern.err kernel: [ 1318.702889] bcm2835-cpufreq:bcm2835_cpufreq_set_clock:84: Failed to set clock: 1400000 (-12)
Sat Dec  8 13:57:42 2018 kern.err kernel: [ 1318.717446] bcm2835-cpufreq:bcm2835_cpufreq_driver_target_index:183: Error occurred setting a new frequency (1400000```

Well, and I tried OpenWrt SNAPSHOT r8663-1286c55 / LuCI Master (git-18.340.83538-1b26c91) as of a couple of minutes ago. It is the same as I reported. NON WORKING. As it is with the "offocial" image 18.06.1.

Setting country code manually via "iw reg set DE" doesn't change anything. The WiFi is never working as AP.

Here is the /etc/config/wireless of mine:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option hwmode '11g'
        option htmode 'HT20'
        option country 'DE'
        option legacy_rates '1'
        option channel '7'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option ssid 'OpenWRT'
        option encryption 'psk2+ccmp'
        option key 'someKEY'
        option wpa_disable_eapol_key_retries '1'
        option isolate '1'
        option mode 'ap'

kernelmessages reports:

[...]
[    7.781815] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    7.818523] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt failed with error -2
[    7.833653] brcmfmac mmc1:0001:1: Falling back to user helper
[    7.848118] firmware brcm!brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt: firmware_loading_store: map pages failed
[    7.957794] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    7.979443] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar  1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4
[    8.025302] usbcore: registered new interface driver brcmfmac
[...]

I'm using the Raspberry Pi 3 Model B Plus Rev 1.3 and snapshot image "openwrt-brcm2708-bcm2710-rpi-3-squashfs-factory.img" and my config:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option htmode 'VHT80'
	option country 'US'
	option legacy_rates '0'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid ‘XXXXXXX’
	option network 'lan'
	option encryption 'psk2'
	option key ‘XXXXXXXXXXXXXX’
	option wpa_disable_eapol_key_retries '1'

Well, all my experiments and experiences I made with the ext4-image. I realise some strange misbehaviours on those images since I use them: sometimes the filesystem renders corrupt after I try to save config changes or the filesystem sitches magically to "read only". I changed SD cards, but the problem ist persistent.

The squashfs image as of today ( Sun Dec 9 00:13:45 2018, https://downloads.openwrt.org/snapshots/targets/brcm2708/bcm2710/) is useless: all Raspberry Pi 3B+ I use boot up and then they reboot after one or two seconds due to a unreadable error telling something about memory before it vanishes. Too fast for my eyes.

I checked also the suggestions made herein switching the country code manually via "iw reg set DE" or just for some other countries. It seems that this procedure changes nothing, I do not trust "iw reg get" - I do not see something serious reporting from the kernel.

@jeff1: your config says you're utilising the 5 GHz broadband - I have no client with such capabilities at hand, most of my systems (native FreeBSD systems) have 802.11n at max. It is interesting, I never achive channel 36, hwmode 11a. That means: I do not know how to get reliable informations from the kernel. I do not trust this Linuxism shell crap covering so much of the essentials. More important, my WiFi is ALWAYS stuck in Client-mode, whatever I do.

I tried to apply the BLOBs taken from Raspberry Pi Org, from there I took firmware-brcm80211_20161130-3+rpt4_all.deb, that is the latest offered BLOB for 3B+ as far as I could investigate. I didn't try the rpt3 so far. One need to install the follwing packages: binutils (for tar and ar) as well as xz to unxz the "data.tar" first. I skip the procedure. Once un-tar'ed, you need to copy the proper sdio-bins from the extraction location into /lib/firmware/brcm/. But I'm not sure whether the rpt4 repository contains the correct images for the proper kernel OpenWRT is running this moment.
Rebooting shows - in my case, now a different picture. It seems the WiFi is now being "stuck" in AP (or Master) mode and is also stuck at channel 36 of 802.11ac. Since I can not check whether my devices around here getting any SSID from my OpenWRT-driven Raspberry Pi 3B+, I'm still able to scan and get spots in the neighbourhood (as I did previously).

The question now is: could it be, despite what the config says, that the device is always configured as 802.11ac device? I have the strange ffeling that some of this crap scripts are not getting/setting the correct parameters and I'm not able to switch modes manually. As said, I'm unfamiliar with Linux, for good reasons.

At this point I'll give up. I'll try the 18.06.1 squashfs image and will try tomorrows squashfs nightly build. After that I'll stop here and give up using OpenWRT. It might be "a great piece of software", but declaring 18.06.1 working on a RaspPi 3B+ despite the fact that it definitely isn't is more than nonprofessional. Sorry. Maybe there is a change in the lates PCB and/or firmware, but I do not care.

@SB211 I checked the wifi 2.4 and the issue seems to be the wireless N removing "ht mode HT20" wifi works perfect in any channel, probably a wifi driver issue.

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option hwmode '11g'
	option channel '9'
	option country 'US'
	option legacy_rates '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option encryption 'psk2'
	option key ‘############’
	option ssid ‘########’```

Well, we are talking about a mysterium magnum without having any reliable refrences - like we do in scientific work.

I have no clue how to extract reliable informations from the kernel about the actual settings - and not the gibberish LUCI tells me.

Just for the record:
I use this moment the ext4-image of snapshots: OpenWrt SNAPSHOT r8669-0bce890 / LuCI Master (git-18.340.83538-1b26c91)
Linux Kernel is at 4.9.138

My device(s) is (are):
Raspberry Pi 3 Model B Plus Rev 1.3

I do not know how to list the devices and their revision numbers aboard. Since WiFi and Ethernet PHYS are bound to the USB subsystem, I'd asume some vendor IDs, product numbers and revisions, but this is naive view.

The squashfs image (snapshot) crashes very shortly after booting and ends up in a bootloop. The official 18.06.1 squashfs doesn't even boot, as mentined above. I guess there is something terribly wrong with the layout to bootstrap the 3B+.

From the RaspberryPi foundation, I took the latest both firmware .deb files as mentioned in an earlier post and replaces now the drivers under /lib/firmware/brcm/ with those extracted from gtp4 repository. Additionally, I also exchanged /boot/bcm2710-rpi-3-b-plus.dtb with the latest found at
https://github.com/raspberrypi/firmware/blob/master/boot/bcm2710-rpi-3-b-plus.dtb

and did the same with bootcode.bin from the very same repository as mentioned in the line above.

While with the daily OpenWRT snapshot the WiFi channel is stuck at channel 1 of 802.11n, no matter what I configure or try to force, with the additions made as described above I see the WiFi device stuck at 802.11ac, but flipping between some channels, mostly 36, 140. Taking this information as a actual one, I'm able to scan while the WiFi is still in STA mode. Whatever I try to configure via /etc/config/wireless, the device never switches into AP mode that way. The command

"iw reg get" results in:

global
country DE: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

So, the setting from the config are effective.

This is, so far, what I have gotten from dmesg:

[...]
[    6.335601] bcm2835-aux-uart 3f215040.serial: irq not found - -517
[    6.342371] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    6.375597] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt failed with error -2
[    6.379268] brcmfmac mmc1:0001:1: Falling back to user helper
[    6.391848] firmware brcm!brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt: firmware_loading_store: map pages failed
[    6.529721] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    6.541476] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
[    6.574101] bcm2835-aux-uart 3f215040.serial: irq not found - -517
[    6.575205] usbcore: registered new interface driver brcmfmac
[    6.577731] kmodloader: done loading kernel modules from /etc/modules.d/*
[    8.123814] lan78xx 1-1.1.1:1.0 eth0: kevent 4 may have been dropped
[    8.127924] br-lan: port 1(eth0) entered blocking state
[    8.128883] br-lan: port 1(eth0) entered disabled state
[    8.129987] device eth0 entered promiscuous mode
[    8.131649] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[    9.439221] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    9.444858] br-lan: port 2(wlan0) entered blocking state
[    9.446924] br-lan: port 2(wlan0) entered disabled state
[    9.449224] device wlan0 entered promiscuous mode
[    9.501273] device wlan0 left promiscuous mode
[    9.503241] br-lan: port 2(wlan0) entered disabled state
[   11.359028] br-lan: port 1(eth0) entered blocking state
[   11.360849] br-lan: port 1(eth0) entered forwarding state
[   11.363556] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

My device acts as you describe stuck at channel 1 of 802.11n, changing from wireless N to Legacy on LUCI interface wifi works

Capture3

I can confirm, with the latest snapshot as reported (OpenWrt SNAPSHOT r8669-0bce890 / LuCI Master (git-18.340.83538-1b26c91)) switching to "Legacy" does the trick :frowning:

I just also confirmed with the most recent official Raspbian Release as of November, 2018, by configuring a bridge and manually setup hostapd.conf as described in several forae, that the hardware of the Raspberry Pi 3B+ of mine is intact and working well. I was able to configure and start an AP as desired.

Thank you very much for your assitance.

Kind regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.