Raspberry 3 LAN WAN Help needed

Hello to the board. First oaf all: Please excuse if my English is not that good - hopefully you will understand my problem. :slight_smile:
So here we go: I am behinf a AVM Router "Fritz.Box 7390." with IP
I installed LEDE on a Raspberry Pi 3 and assigned on "eth0"
I can reach the Gui and the SSH Connect also works. I bought a TP-Link UE300 USB/LAN Adapter in order to connect the PI directly behind the Fritz.Box Router. I created an interface "eth1" using DHCP client mode and connected the LAN Port of the AVM Router to the USB/Lan Adapter - no connection.
Here are 2 questions: What IP do I have to assign to the WAN interface (DDNS Account possible?) to get at least a connection to the Internet.
The UE300 should work out of the box with Rasbian. How to manage my problem with LEDE?
Any help would be appeciated. Thanks in advance- you all have a great weekend.
Regards from Germany.

Its not really clear to me what kind of network you want to set up.

telco-router <--wifi--> LEDE <--wired--> PC ?

You wrote about LAN and WAN, do you want to route on the LEDE bnox or do you want to bridge them all into one broadcast network?

Routing: between Fritz and LEDE, for instance between LEDE and PC, firewalled so you have different "security zones"?

Bridging: All devices are in the broadcast network range, you try to use LEDE as as a network distribution bridge?

Odie, thanks for the quick reply. I wanted to setup Fritz<--wired--> LEDE <-- wired --> Switch <-- wired --> Win Clients
Normally all devices are in so different "security zones" like you told ( would be great.
Bridging would also be ok. What is not clear for me: Which version could be manages with only the eth0 interface of the pi?


If your switch is VLan capable you could use two VLan Interfaces on the pi's one interface side and a trunk on your switch port.

If not or if this sounds strange to you because you havn't done such setups yet you could use a secondary virtual ip address on port eth0:1 of your pi's eth0.

Or you simply use an additional usb network adapter. In order to make these work you need to install the needed kmod-* package. (Openwrt/LEDE is a little different than "normal" Linux distros in driver management, they are not all installed by default).

Your UE300 uses the RTL8153 chipset, try installing kmod-usb-net-rtl8150 or kmod-usb-net-rtl8152, maybe you are lucky and one of them works.

If your pi can ping your fritz router when connected to lan but not the rest of the internet try

route add -net default gw
echo "nameserver" >>/etc/resolv.conf
ping google.de (or someserver else:)

If you can ping outbound install the driver for eth1, either via LuCi or on the shell

opkg update
opkg install kmod-usb-net-rtl8152

Thanks again - I will try that and report..

My Orico HR02 nic-hub combo works with kmod-usb-net-rtl8152, good chance your UE300 does too

root@lede:~# lsusb
Bus 002 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
mii 3328 5 mcs7830,ax88179_178a,usbnet,r8169,r8152

Odie, thanks again. I did like you told me.
Here are the results:
root@lede:~# lsusb
-ash: lsusb: not found

root@lede:~# lsmod
brcmfmac 160604 0
brcmutil 4032 1 brcmfmac
cfg80211 226160 1 brcmfmac
compat 8128 2 brcmfmac,cfg80211
crc_ccitt 1024 1 ppp_async
evdev 10112 0
fat 44128 1 vfat
hid 80724 2 usbhid,hid_generic
hid_generic 640 0
ip6_tables 9432 2 ip6table_mangle,ip6table_filter
ip6t_REJECT 1024 2
ip6table_filter 640 1
ip6table_mangle 1024 0
ip_tables 9700 3 iptable_nat,iptable_mangle,iptable_filter
ipt_MASQUERADE 704 1
ipt_REJECT 896 2
iptable_filter 704 1
iptable_mangle 832 0
iptable_nat 832 1
nf_conntrack 57068 9 nf_nat_ipv4,nf_conntrack_ipv6,nf_conntrack_ipv4,xt_state,xt_conntrack,xt_CT,nf_nat_masquerade_ipv4,nf_nat,nf_conntrack_rtcache
nf_conntrack_ipv4 5376 9
nf_conntrack_ipv6 5824 4
nf_conntrack_rtcache 2432 0
nf_defrag_ipv4 960 1 nf_conntrack_ipv4
nf_defrag_ipv6 13140 1 nf_conntrack_ipv6
nf_log_common 2304 2 nf_log_ipv4,nf_log_ipv6
nf_log_ipv4 3200 0
nf_log_ipv6 3648 0
nf_nat 9224 4 nf_nat_ipv4,xt_nat,nf_nat_redirect,nf_nat_masquerade_ipv4
nf_nat_ipv4 3586 1 iptable_nat
nf_nat_masquerade_ipv4 1348 1 ipt_MASQUERADE
nf_nat_redirect 896 1 xt_REDIRECT
nf_reject_ipv4 1856 1 ipt_REJECT
nf_reject_ipv6 2112 1 ip6t_REJECT
nls_cp437 4480 1
nls_iso8859_1 2944 1
nls_utf8 896 0
ppp_async 6404 0
ppp_generic 19920 3 pppoe,ppp_async,pppox
pppoe 7808 0
pppox 1168 1 pppoe
r8152 29056 0
slhc 4416 1 ppp_generic
snd 39712 9 snd_bcm2835,snd_compress,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device,snd_hwdep
snd_bcm2835 15132 0
snd_compress 6400 0
snd_hwdep 4484 0
snd_mixer_oss 11648 1 snd_pcm_oss
snd_pcm 59464 3 snd_bcm2835,snd_pcm_dmaengine,snd_pcm_oss
snd_pcm_dmaengine 2112 0
snd_pcm_oss 31200 0
snd_rawmidi 14880 0
snd_seq_device 1988 1 snd_rawmidi
snd_timer 15816 1 snd_pcm
soundcore 3656 1 snd
usbhid 22740 0
vfat 7936 1
x_tables 9412 23 ipt_REJECT,ipt_MASQUERADE,xt_time,xt_tcpudp,xt_state,xt_nat,xt_multiport,xt_mark,xt_mac,xt_limit,xt_conntrack,xt_comment,xt_TCPMSS,xt_REDIRECT,xt_LOG,xt_CT,iptable_mangle,iptable_filter,ip_tables,ip6t_REJECT,ip6table_mangle,ip6table_filter,ip6_tables
xt_CT 2560 0
xt_LOG 832 0
xt_REDIRECT 704 0
xt_TCPMSS 2624 0
xt_comment 512107
xt_conntrack 2368 12
xt_limit 1220 20
xt_mac 640 0
xt_mark 704 0
xt_multiport 1280 0
xt_nat 1216 0
xt_state 768 0
xt_tcpudp 1728 8
xt_time 1664 0
For it looks like no support yet in my system. The UE300 got the RTL8153 chip. I couldn´t find a driver in the LEDE available package section.
Anyway thank you for the support.

Just install kmod-usb-net-rtl8152, worked with my rtl8153 device.

Good luck!

Thats what I did. r8152 shows up in "lsmod" but no similar interface - only eth0.

Hmmmm... Is r8152 loaded and known to mii?

Here on my Atom box:

root@lede:~# dmesg | grep r8152
[ 6.916494] usbcore: registered new interface driver r8152
[ 7.047378] r8152 2-1.1:1.0 eth1: v1.08.2
[ 11.323264] r8152 2-1.1:1.0 eth1: Promiscuous mode enabled

root@lede:~# lsmod | grep r8152
mii 3328 5 mcs7830,ax88179_178a,usbnet,r8169,r8152
r8152 30016 0

Are there different Versions of the UE300? Those with usb id 2357:0601 seem to be recognized as cdc_ether.


TP-Link says RTL8153...

2.629838] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:99:1a:dd
[ 2.876951] usb 1-1.5: new high-speed USB device number 4 using dwc_otg
[ 2.997691] usb 1-1.5: New USB device found, idVendor=2357, idProduct=0601
[ 3.006905] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=6
[ 3.016561] usb 1-1.5: Product: USB 10/100/1000 LAN
[ 3.023716] usb 1-1.5: Manufacturer: TP-LINK
[ 3.030266] usb 1-1.5: SerialNumber: 000001000000

root@lede:~# dmesg | grep r8152
[ 6.458854] usbcore: registered new interface driver r8152

it is still no eth1 inerface loaded. I could post the hole dmesg if that would help but I didn´t want to flood this post.

EDIT: It seems it is that device as from that post from "askubuntu.com"
I will have a look what cdc_ether means.. :slight_smile:

I installed usbutils. Now lsusb says:
root@lede:~# lsusb
Bus 001 Device 004: ID 2357:0601
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I'm running out of ideas with your usb net dev (,maybe your ue300's usb id is missing in r8152.ko) :slight_smile:

In this case, if your switch doesnt support vlans, i would try a simple alias config in /etc/config/network, but i was never in a situation where i had to try this. :wink:

config interface wan
option 'ifname' 'eth0'
option 'proto' 'static'
option 'ipaddr' ''
option 'netmask' ''
option 'gateway' ''
option 'dns' ''

config interface lan
option 'ifname' 'eth0'
option 'proto' 'static'
option 'ipaddr' ''
option 'netmask' ''

See: https://wiki.openwrt.org/doc/uci/network#aliasesthe_new_way

Fritz --- Switch --- Raspi
(______)| ------- Client on

Holy Cow - I am working with the Pi and Rasbian for 1 year now...but couldn´t get into LEDEs Bash. I will stop this project for a time and try to get deeper in it.
By the way: The UE300 is recognized on Rasbian Jessi out of the box as eth1.
Thanks again,