Ramips/mt7621 sysupgrade from snapshot buildbot image - SOLVED

Hi, I noticed that after I sysupgraded my WNDR700v5 (ramips/mt7621) with a Jun 6th image and rebooted - the kernel version and Openwrt snapshot revision shown was an older version from May 23rd 4.14.42.

The buildbot image logs show the latest kernel committed as version v4.14.48

uname -a 
Linux openwrt 4.14.42 #0 SMP Wed May 23 07:32:25 2018 mips GNU/Linux
OpenWrt SNAPSHOT, r7019-1289e00

I have performed the sysupgrade twice via Luci GUI and commandline and the same result. I cannot see any errors or problems with the sysupgrade process and the image from June 6th should produce an OpenWRT build higher than r7019


The wifi must be turned off so be sure to do this over wired connection

wifi down
cd /tmp
curl -o "https://downloads.lede-project.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-wndr3700v5-squashfs-sysupgrade.bin"
sha256sum openwrt-ramips-mt7621-wndr3700v5-squashfs-sysupgrade.bin
sysupgrade -c -v openwrt-ramips-mt7621-wndr3700v5-squashfs-sysupgrade.bin

Sysupgrade breaks apparently because hostapd or other processes refuse to be killed. Issue wifi down and then run sysupgrade (if you upgrade wirelessly, combine it into one command).

@Borromini Thanks. Yep turning off wifi did the trick. Post updated

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.