Ramips Image Size "exploding"


Running in to a bit of an odd finding - building for a HooToo ht-tm05, but I don't think the issue is really just for this particular target. The steps I went through,

  1. Start with an empty .config file - to begin clean.
  2. Gradually (one by one), add items to the build. After each one ... make clean, and then build the image. The size (and delta) of the resulting sysupgrade.bin file is below. All is good until I add in kmod-crypto-kpp ... which I'm not sure I need, I was just trying to get back to an old working build (and I checked from the diffconfig I had saved what all was in the build). But the end result is too large ... sysupgrade only builds because I forced it (to see how large it really is).
  3. So then I tried (last line) to remove kmod-crypto-kpp, get back to where I was ... but no joy :frowning_face:. Rather, the image does not "shrink" back to the size it was previously.

I tried a few things to debug,
a) I had saved a diffconfig before adding kmod-crypto-kpp, but trying to use that again ... nope, still "stuck" at the too large size.
b) I had also saved the .config file before the addition, but using that ... same issue.

Seems something is "stuck", so I can't get back to a clean build. I did make clean, even tried make dirclean ... but nothing. I did try cleaning linux (make target/linux/clean), still no improvement. What the heck is "stuck"?!?! Very odd. Just trying to get back to the smaller build again.

And a couple other observations / questions,

  • if I just go straight to the luci-compat row, all at once (from diffconfig) ... kmod-crypto-kpp seems to get added in, so the image size explodes. But step by step (row by row), it works, and is much smaller (kmod-crypto-kpp not included). Seems like some sort of inconsistency in the build dependencies?
  • I did try changing to the testing kernel, just to see if that cleaned Linux, and got back to the smaller build. Nope, exactly the same size.
  • is there a way (in menuconfig?) to see the tree of dependencies? In other words, what all will be added, if a package / module is included? Not just one level down (this is clear from help in menuconfig), but the full tree below that.

I may just be going crazy, that's entirely possible too :laughing:. Any thoughts would be greatly appreciated! The first step of course - how the heck to get back to the smaller build (with the saved .config file)? I'm not sure what I'm not cleaning, but it seems like there is something in there, that even survives dirclean.


to check for dependencies you can use package table on the wiki.

but as you see that package has no dependency.

And this is in the build system source where that package is defined and what kernel symbol it activates

as for your problem, i have no idea about a proper fix

You can do a make distclean and that will delete the toolchain and the config and everything else and bring you back to everything as after you did git clone from the repository.
I think that should work, but it is not a real solution, it's just a more through clean that can help work around the issue


Yep, distclean did it - as you say, a bit "overclean" ... LOL. But took care of the issue. Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.