R7800 SQM settings keep causing bufferbloat

I've done almost everything i can think of before coming to forums to complain to get help :\

Can someone assist me to see what i'm doing wrong?

A little brief information on what i understand about OpenWrt... I've first started using OpenWrt for my Netgear WNDR3700v4 while a family member was away and i told him and he got mad i messed with his router firmware and wanted it reverted so i reverted it back to factory, before i was seeing from Grade C to Grade A/A+. Now i keep getting with this R7800 Grade C to Grade C... NO CHANGES.

If anyone wants to read the last thread i created like a month ago for the WNDR3700v4, i went and did all this like moeller0 explains and for some reason the one labeled "wan/wan6" doesn't do jack aka (eth0.2) while eth0 is the one that is right. Too much conflicting info from alot of users on forums. Several users said to go with the one that is labeled wan and it did not get any good results. With Eth0, using OpenWrt documentation, it was right on the money!

Now... Current day, for some reason doing the same with this router will not get me the same results. I get around 0-13ms download bufferbloat and 0-40ms for upload for the first 3 seconds then it jumps to 300ms and stays there till the end of the tests.

Before with my WNDR3700v4, i was getting consistent results of 0-7ms downloads and 0-12ms uploads i believe then i went and gone with moeller0 to see if i can get better results, mind you i'm losing 20% of my bandwith symmetrical downloads and uploads to get lower bufferbloat results. I slowly went from 125000 kbps -> 118750 -> 112500 -> 106250 -> 100000 kbps, with 100 mbps i was seeing A+ grade results, anything above these results (106 mbps/+) i got Grade A.
Like i said above, I'm getting Grade C -> Grade C. No changes.

Settings in OpenWrt:

Basic settings:
Interface name: eth0
Download speed (kbit/s) (ingress) set to 0 to selectively disable ingress shaping:
100000
Upload speed (kbit/s) (egress) set to 0 to selectively disable egress shaping:
100000
Create log file for this SQM instance under /var/run/sqm/${Interface_name}.debug.log. Make sure to delete log files manually.

Verbosity of SQM's output into the system log.

Queue Discipline
Queuing disciplines: Cake

Queue setup script: piece_of_cake.qos

Link Layer Adaption
Which link layer to account for: Ethernet with overhead (Select for e.g. VDSL2.)

Per Packet Overhead (byte): 44

I'm on ATT Fiber. Not sure FTTP or FTTN.

I've tried several interface name changes and went from hyman's 19.07 to 18.06 and regular 18.06 without his compiled package and no difference whatsoever. Diagnosed this for 3 hrs. No success. Anyone have any advice?

I've rebooted, replaced firmware multiple times, router and modem included.

I also used this. This was how i configured it previously.

This sounds like something went wrong. Could you post the putput of the following commands on the command line please:

cat /etc/config/sqm
ifstatus wan
tc -d qdisc
tc -s qdisc
SQM_DEBUG=1 SQM_VERBOSITY_MAX=11 /etc/init.d/sqm stop ; SQM_DEBUG=1 SQM_VERBOSITY_MAX=11 /etc/init.d/sqm start

Maybe one of these might show where things go off the rails

I will get right on it once i finish couple jobs at this time.

Note:** I like using Layer_cake.qos, i've done this couple times swapping from Layer_cake.qos to piece_of_cake.qos and saw some difference playing games. However, there is no difference between these two when getting Grades for bufferbloat though.

I like DSCP, don't know whether the DSCP incorporated in Gpedit in windows makes much difference but i do feel a bit lower latency with Layer_cake.qos enabled than piece_of_cake.qos

I've uninstalled irqbalance from software GUI because i read something on hnyman R7800 build thread by other users of rebooting issues? I just had a random reboot out of nowhere 2 1/2 hrs ago.

^ Reinstalled irqbalance.

cake is pretty complex its in calculations and does maybe not quite suit into the dual-core CPU-scaling ipq8065 in R7800. Varying CPU speeds may throw the calculations off.

Some ideas:

  • You may need to disable the CPU frequency scaling and keep the router on full CPU 1.7 GHz all the time (so that it does not scale down to 0.384 GHz when idling). Use "performance" governor instead of "ondemand".
  • change the kernel parameters for CPU scaling. Example:

echo 35 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 10 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor

Personally I use simple.sqm with fq_codel and not cake with my R7800.

You might read the discussion from:

Microsoft Windows [Version 10.0.17763.557]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>ssh root@192.168.1.1
root@192.168.1.1's password:


BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06-SNAPSHOT, r7803-5e771160b8
 -----------------------------------------------------
root@OpenWrt:~# cat /etc/config/sqm

config queue 'eth0'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option qdisc 'cake'
        option linklayer 'ethernet'
        option overhead '44'
        option download '100000'
        option upload '100000'
        option interface 'eth0'
        option script 'layer_cake.qos'
        option qdisc_advanced '1'
        option squash_dscp '0'
        option squash_ingress '0'
        option ingress_ecn 'ECN'
        option egress_ecn 'ECN'
        option qdisc_really_really_advanced '0'

root@OpenWrt:~# ifstatus wan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 20881,
        "l3_device": "eth0.2",
        "proto": "dhcp",
        "device": "eth0.2",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "***.***.***.**",
                        "mask": 22
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "***.***.***.*",
                        "source": "***.***.***.**\/32"
                }
        ],
        "dns-server": [
                "192.168.2.254"
        ],
        "dns-search": [
                "attlocal.net"
        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ]
        },
        "data": {
                "leasetime": 600
        }
}
root@OpenWrt:~# tc -d qdisc
qdisc noqueue 0: dev lo root refcnt 2
qdisc cake 8004: dev eth0 root refcnt 9 bandwidth 100Mbit diffserv3 triple-isolate nonat nowash no-ack-filter split-gso rtt 100.0ms noatm overhead 44
qdisc ingress ffff: dev eth0 parent ffff:fff1 ----------------
qdisc mq 0: dev eth1 root
qdisc fq_codel 0: dev eth1 parent :1 limit 10240p flows 1024 quantum 1514 target 5.0ms interval 100.0ms memory_limit 4Mb ecn
qdisc noqueue 0: dev br-lan root refcnt 2
qdisc noqueue 0: dev eth1.1 root refcnt 2
qdisc noqueue 0: dev eth0.2 root refcnt 2
qdisc cake 8005: dev ifb4eth0 root refcnt 2 bandwidth 100Mbit diffserv3 triple-isolate nonat nowash no-ack-filter split-gso rtt 100.0ms noatm overhead 44
qdisc noqueue 0: dev wlan1 root refcnt 2
qdisc noqueue 0: dev wlan0 root refcnt 2
root@OpenWrt:~# tc -s qdisc
qdisc noqueue 0: dev lo root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc cake 8004: dev eth0 root refcnt 9 bandwidth 100Mbit diffserv3 triple-isolate nonat nowash no-ack-filter split-gso rtt 100.0ms noatm overhead 44
 Sent 115755626 bytes 1239965 pkt (dropped 2, overlimits 7314 requeues 39194)
 backlog 0b 0p requeues 39194
 memory used: 26Kb of 5000000b
 capacity estimate: 100Mbit
 min/max network layer size:           28 /    1500
 min/max overhead-adjusted size:       72 /    1544
 average network hdr offset:           14

                   Bulk  Best Effort        Voice
  thresh       6250Kbit      100Mbit       25Mbit
  target          5.0ms        5.0ms        5.0ms
  interval      100.0ms      100.0ms      100.0ms
  pk_delay          0us         50us         14us
  av_delay          0us         12us         10us
  sp_delay          0us         10us          7us
  backlog            0b           0b           0b
  pkts                0      1237687         2280
  bytes               0    115547084       210244
  way_inds            0         8076            0
  way_miss            0         8645          273
  way_cols            0            0            0
  drops               0            2            0
  marks               0            0            0
  ack_drop            0            0            0
  sp_flows            0            2            0
  bk_flows            0            1            0
  un_flows            0            0            0
  max_len             0         1514          553
  quantum           300         1514          762

qdisc ingress ffff: dev eth0 parent ffff:fff1 ----------------
 Sent 4971280267 bytes 3719028 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc mq 0: dev eth1 root
 Sent 5091032555 bytes 3737727 pkt (dropped 0, overlimits 0 requeues 194908)
 backlog 0b 0p requeues 194908
qdisc fq_codel 0: dev eth1 parent :1 limit 10240p flows 1024 quantum 1514 target 5.0ms interval 100.0ms memory_limit 4Mb ecn
 Sent 5091032555 bytes 3737727 pkt (dropped 0, overlimits 0 requeues 194908)
 backlog 0b 0p requeues 194908
  maxpacket 1514 drop_overlimit 0 new_flow_count 185810 ecn_mark 0
  new_flows_len 0 old_flows_len 0
qdisc noqueue 0: dev br-lan root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc noqueue 0: dev eth1.1 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc noqueue 0: dev eth0.2 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc cake 8005: dev ifb4eth0 root refcnt 2 bandwidth 100Mbit diffserv3 triple-isolate nonat nowash no-ack-filter split-gso rtt 100.0ms noatm overhead 44
 Sent 5053400499 bytes 3718318 pkt (dropped 710, overlimits 538668 requeues 0)
 backlog 0b 0p requeues 0
 memory used: 1244864b of 5000000b
 capacity estimate: 100Mbit
 min/max network layer size:           46 /    1500
 min/max overhead-adjusted size:       90 /    1544
 average network hdr offset:           14

                   Bulk  Best Effort        Voice
  thresh       6250Kbit      100Mbit       25Mbit
  target          5.0ms        5.0ms        5.0ms
  interval      100.0ms      100.0ms      100.0ms
  pk_delay          0us        130us         24us
  av_delay          0us         58us          8us
  sp_delay          0us          8us          6us
  backlog            0b           0b           0b
  pkts                0      3699265        19763
  bytes               0   5053195801      1189910
  way_inds            0        28445            0
  way_miss            0         9167            3
  way_cols            0            0            0
  drops               0          710            0
  marks               0           14            0
  ack_drop            0            0            0
  sp_flows            0            0            0
  bk_flows            0            1            0
  un_flows            0            0            0
  max_len             0        12112          385
  quantum           300         1514          762

qdisc noqueue 0: dev wlan1 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc noqueue 0: dev wlan0 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0

root@OpenWrt:~# SQM_DEBUG=1 SQM_VERBOSITY_MAX=11 /etc/init.d/sqm stop ; SQM_DEBUG=1 SQM_VERBOSITY_MAX=11
SQM: Stopping SQM on eth0
root@OpenWrt:~# /etc/init.d/sqm start
SQM: Starting SQM script: layer_cake.qos on eth0, in: 100000 Kbps, out: 100000 Kbps
SQM: layer_cake.qos was started on eth0 successfully
root@OpenWrt:~#

I tried to input:
root@OpenWrt:~# echo 35 > /sys/devices/system/cpu/cpufreq/performance/up_threshold
-ash: can't create /sys/devices/system/cpu/cpufreq/performance/up_threshold: nonexistent directory
root@OpenWrt:~# echo 10 > /sys/devices/system/cpu/cpufreq/performance/sampling_down_factory
-ash: can't create /sys/devices/system/cpu/cpufreq/performance/sampling_down_factory: nonexistent directory

^ Think i misunderstood what you meant.

Tried this:
root@OpenWrt:~# echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
root@OpenWrt:~# echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

Now in the graphs from your Hnyman build for R7800, went to CPU Freq graph and its 1.73Ghz.

I also tried flow offloading, both software and hardware... Weird how flow offloading requires the software offloading being [X] in order for hardware offloading to be [X]. Barely noticed anything. Tested once again bufferbloat via Dslreports and nothing good visually. I worry that when i'm sleeping as router cpufreq never goes back to idling freqs, my hardware might not last as long or temps will continue to rise over time/frequent reboots. Guess only time will tell what will happen.



So this indicates that sqm on eth0.2 should actually work, so this is quite odd.

The tc output shows that both expected cake instances seem up and running with nothing obvious wrong.

Could you, just for testing change sqm to eth0.2 again and then set

to 50000

and

to 25000
and run a dslreports speedtest and post a link ot the results here, please (keep the frequency at maximum for this test).

Also please post a link to a dslreports speedtest with SQM disabled, please.

It's kinda severe don't you think to go 50% download & 80% upload capped for just bufferbloat, mind you game packets are like 17 KBps for League of legends. I know thats not how it works but very severe case to test like this.

R7800 eth0, 100mbps symmetrical down & up SQM, 25mbps loss of throughput

R7800 eth0.2 change, 100mbps symmetrical down & up SQM, 25mbps loss of throughput. (Only eth0.2 change)

R7800 eth0.2 change, 50mbps down & 25mbps up SQM, over 50% loss of throughput.

R7800 eth0.2 SQM DISABLED change, 50mbps down & 25mbps up SQM, over 50% loss of throughput.

As you can see the results, going from 100mbps down to 50mbps down & 100mbps up to 25mbps up made a difference from Grade C -> Grade A+, what i don't understand is and i hope more users can chime in on this thread, PLEASE :smiley:

I used a WNDR3700v4, like situation i listed above about what had happened, before i was getting these Grades A/A+ if i was using a SINGLE CORE processor router with lower frequency & lower amounts of RAM, never changed the setting on that. Never touched it at the time other than installed UPnP & SQM packages. How does this make any sense that i went from 6250kbps down each 4 times from 125mbps to 100mbps i used to get Grade A/A+ to switching to a R7800 = Grade C? Especially when it has 2 Cpu cores 1.7Ghz and more RAM too, also if anyone says anything about me installing hnyman's R7800 packages, i've tried even the regular 18.06 and it didn't do anything good for me, 18.06 hnyman R7800 & 19.06 Hnyman R7800. Also, doesn't matter if i go with Layer_cake.qos/piece_of_cake.qos with dscp settings enabled. I need others to place their results of what their max throughputs they get and what they lost by trying to achieve a certain Grade in DSLReports. Over 50% loss is too far & differences between routers shouldn't do this.
Sorry, i have to clarify everything so everyone can understand perfectly.

WNDR3700v4 results from May 2019.

Yes, you did.
I wrote "/sys/devices/system/cpu/cpufreq/ondemand/up_threshold" and
you tried "/sys/devices/system/cpu/cpufreq/performance/up_threshold"

There is no up_threshold in the performance governor, as it is always maxed out.

There is that parameter for the ondemand governor (where CPU speed varies according to the load).

I provided two alternatives:

  • use the performance governor (which you have now figured out),
    echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
    or
  • tweak the parameters for the ondemand governor to modify its behaviour to be more eager to max out the CPU.
    echo 35 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
    ...

ondemand has several parameters that were also mentioned/discussed in those threads.

root@router1:~# ls /sys/devices/system/cpu/cpufreq/ondemand/
ignore_nice_load      powersave_bias        sampling_rate
io_is_busy            sampling_down_factor  up_threshold

more info at https://www.kernel.org/doc/Documentation/cpu-freq/governors.txt

Only reason was because you wrote:

"* Use "performance" governor instead of "ondemand"."

so i took that as reasoning to have to change the command just a little to fit with what i wanted as you wrote it as an example. Sorry.

Also, i'll just stick to this one. If should i need to for any reason to go with the other one you listed as an alternative i'll try it out. I typically pretty much want it to be maxed out on performance imo to begin with.

EDIT: ** 6/30/2019, 1:56AM, CPU Freq changed back to idling or using ondemand because i had a issue with my modem for some reason resetting all its settings when i woke up and tried to get into my modem gateway address to config it and couldn't because everything was reset. My brother then turned off the surge protector and waited couple minutes then turned it back on and my R7800 is back to its idling freq states. >_<

moeller0, can you send me details on whats your downloads/uploads and whats your SQM settings to compare?

I've also found this article & thread.


I believe it has to do with DHCP being left on in the settings of my ATT gateway, i've tried to disable it but after i restart my modem, i can't reconnect so i have to reset the gateway and i lose like 5 minutes of my day each time trying to reconfig it over and over again to see if i might have done it wrong in some way or another.

The article talks about how this can affect QoS which SQM is a form of QoS.
LuCi GUI says i'm getting the Public IP Address passed-through from my modem to router properly as i set via "IP Passthrough" but when checking via tracert i notice two private IP's and then my public IP.
I can't seem to fix that.

Thanks for the data. First, the idea behind shaping to 50/25 was only to see whether at such extreme bandwidth sacrifice sqm/cake manage to work as intended, and indeed they do.

Comparing the dslreports detailed results pages indicates that the upload direction is the problem, download looks actually pretty good compared to without sqm. That means you can set downloading to 100 and we can concentrate on the upload side.
I would now iterativelyv search for the highest upload rate that still results in acceptable bufferbloat, for that test I would set the governor to performance again to only deal with one issue at a time....

I can post my settings later today, when I have access to that data again.
About double NAT, sure it has its challenges, but traffic shaping typically is not among them. I can see how port and IP based QoS schemes need special care or run into insurmountable issues, but I believe that this is not your biggest issue right now.

Sure here is my /etc/config/sqm:

config queue
        option debug_logging '0'
        option verbosity '5'
        option qdisc_advanced '1'
        option squash_dscp '0'
        option squash_ingress '0'
        option ingress_ecn 'ECN'
        option egress_ecn 'ECN'
        option qdisc_really_really_advanced '1'
        option linklayer 'ethernet'
        option overhead '34'
        option linklayer_advanced '1'
        option tcMTU '2047'
        option tcTSIZE '128'
        option linklayer_adaptation_mechanism 'default'
        option iqdisc_opts 'nat dual-dsthost ingress'
        option eqdisc_opts 'nat dual-srchost'
        option interface 'pppoe-wan'
        option qdisc 'cake'
        option script 'layer_cake.qos'
        option tcMPU '68'
        option enabled '1'
        option download '49000'
        option upload '9500'

you will notice I have a much slower link (50/10) and an ISP that insists upon using PPPoE.

About double NAT, I rethought this and cake's per-internal-IP fairness will still works, because even after double NAT the internal IP addresses are unambiguous and resolved by cake's deNATting, so while double NAT is far from double fine, I would recommend to deal with that issue later (if at all)

Gotcha, but one thing that still itches me is not understanding why one router requires a huge loss of bandwidth comparing between the two. I hope i find out the cause of this if not someone has an answer for this issue.

Also, i noticed you only took a 1mbps dive on down & 500kbps on ups. What grade are you getting?

I never knew CAKE can deNAT.

Let's first figure out how much bandwidth sacrifice is actually needed, and then we can try to figure out the root cause?

Well, I tried iteratively to "optimise"these settings. Also note the option iqdisc_opts 'nat dual-dsthost ingress' line, the ingress keyword makes cake shape the ingress so that the incoming rate is targeted, which results in more aggressive shaping which in turn allows to set the shaper closer to the real limit. On egress, in theory shaping should work at 100% of the real egress rate, so shaving off 5% is already more than theoretically required, one of my issues is, that I know my ISP employs a shaper at its BNG level, but I have no information about that shaper's setting so I need to approximate those limits. (And I value keeping latency low over maxing out the bandwidth, so I could not care less about even trading 10-20% of bandwidth for consistently low latency-under-load-increase. but this is a policy issue, and I fully understand that other's have different policies.)

Mostly A+ and occasionally As, but I tend to look more at the detailed bufferbloat plots anyway, the grades are too coarse for my taste.

Well, this is one of the cool features which allows cake to get to the real internal and external addresses basically virtually undoing the NAT masquerading, and that in turn allows the nifty per-internal or per-external IP address fairness modes (in my config nat dual-dsthost in ingress and nat dual-srchost on egress fairly share download and upload bandwidth between all concurrently active internal host addresses, so no computer can easily take over the network completely)

Ok, i'm fine with that. I will be patient. :slight_smile:

Well, I tried iteratively to "optimise"these settings. Also note the option iqdisc_opts 'nat dual-dsthost ingress' line, the ingress keyword makes cake shape the ingress so that the incoming rate is targeted, which results in more aggressive shaping which in turn allows to set the shaper closer to the real limit. On egress, in theory shaping should work at 100% of the real egress rate, so shaving off 5% is already more than theoretically required, one of my issues is, that I know my ISP employs a shaper at its BNG level, but I have no information about that shaper's setting so I need to approximate those limits. (And I value keeping latency low over maxing out the bandwidth, so I could not care less about even trading 10-20% of bandwidth for consistently low latency-under-load-increase. but this is a policy issue, and I fully understand that other's have different policies.)

^ I too prefer low latency over bandwith, I also went with 20% reduction in total throughput as latency is a big must for me.

Mostly A+ and occasionally As, but I tend to look more at the detailed bufferbloat plots anyway, the grades are too coarse for my taste.

^That's great for the very little loss.

Well, this is one of the cool features which allows cake to get to the real internal and external addresses basically virtually undoing the NAT masquerading, and that in turn allows the nifty per-internal or per-external IP address fairness modes (in my config nat dual-dsthost in ingress and nat dual-srchost on egress fairly share download and upload bandwidth between all concurrently active internal host addresses, so no computer can easily take over the network completely)

Ooh, i think i might try nat dual-dsthost and nat dual-srchost, i forgot to mention but with SQM disabled i think i was getting less bufferbloat with it jumping around compared to enabled. I might have to retest but still got the same grade overall though.

Hi Hnyman, I've been researching on my problem. the performance governor imo barely does much as i don't notice anything when doing dslreports performance tests, it doesn't really mitigate bufferbloat imo from just bring the Cpu Frequency to max.

  1. Also if i reboot my router, the router running at 1.73Ghz goes back to idling afterwards.
    Is there any command i can insert in CLI to get it to stay at 1.73Ghz possibly?
    Or maybe i should just go with the other alternative you left me.

  2. Right now i figured out couple things, i'm talking to mindwolf via private message to see if my issue is similar to his because he had a issue with SQM not working right or something to do with the R7800 build possibly?

I asked him for help and he willingly kindly helped me out.
Right now I've figured out something is the issue with SQM, if i insert the command for the upload, it works fine, i get A/A+ Grade but with SQM through GUI, it does not work properly.

Right now i need to know what the command to get the downloads to work as my downloads were at 126mbps and uploads were like 93-100mbps.

  1. I am curious, do you use SQM via CLI or GUI? Majority use it via CLI i'm sure.
    Could i get one command for layer_cake.qos & one command for piece_of_cake.qos with both download and uploads at 100mbps bandwith dual srchost & dual dsthost?

I want to do individual tests between layer_cake.qos & piece_of_cake.qos. I don't want to continually ask one at a time so i'll ask for both. :smiley:

  1. Just had the second crash on this router in 2 weeks of ownership or so. How should i go about testing or checking for what caused it?

P.S. Mindwolf told me he was testing my uploads because he thought that was the issue and we're going off one thing one at a time to figure stuff out.

Thank you!

This might help you

Okay, will do this later in day. Have to sleep, appreciate the help :smiley: