R7800 SQM performance

becuase before firewall apply of sqm doesn't control my latency well, restarting service makes it work right

though even loading before shows true values in uci but not working well, so a restart after complete boot helps alot

thanks for module tip, removed and it's not finding this module now and err gone

moreover changing 50 to 99, tried 85 also, but service is not loading, idk why, it should, any script to restart service and revert init.d value of sqm to 50? any ideas?

That is an indication of problems with hotplug... might be worth trying to figure out why hotplugging is not working as expected...

Well, UCI just tells you the content of the config file to see what is actually instantiated run tc -s qdisc and confirm that the expected qdisc operates on the expected device.

Not really, except I believe we should concentrate on figuring out why hotplugging does not seem to work.

1 Like

removing s50sqm from rc.d fixed it and it auto generated new s85sqm in rc.d and sqm service is loaded properly at 85, but firewall reloading going always after it, no matter what service number i assign, a rstart of sqm service after complete boot can help , any guidelines for such script?

as nothing in logs and all looks good in tc -s qdisc, so only i thought of restart service again

would it possible to split this 30-message long SQM discussion, mainly between between immi803 and moeller0, away from the R7800 thread, as this has pretty much nothing to do specifically with R7800 hardware.

(The R7800 DSA discussion gets swamped...)

1 Like

really sorry for this, you're right @hnyman
gonna switch it some relevent thread

BTW rocking your latest vht160 fixed build :slight_smile: Thank you

Moved to separate topic.
Please adjust the topic title / category as needed.


I see very consistent dslreport A+ results but getting latency on CODm on wifi, researching , came across hisham dscp marks and related veth stuff
On CODm , while playing good below 40ms , it surges to 199ms

I've wan at eth0.2 , as pppoe-wan and lan at eth1, do i need veth? Or just dscp-ipv4.sh only will do the trick?
Looking for help

This might be related to WiFi then?

You might want to ask this in one of @hisham2630's threads...

1 Like

i'm not sure , ifit's related to wifi, as getting same results for upstream ATH10K Main and ATH10K-CT, so doesn't look wifi

I'll ask about script in relevant hisham thread, Thanks for replying