R7800 - Instability when initially connecting via wireless

First off, thanks to all the people here who work on this project - you unbricked my router! I had upgraded the factory firmware the other day and it killed my wireless radios. OpenWRT brought them back to life!

Most everything is chirping along nicely with openwrt now, except when I first connect via wireless to the router. The connection is unstable, slow, dropping packets, etc... After a few minutes, everything is fine and continues to be unless I reboot/let the device sleep. I have noticed this on all my devices, not just one.

I see nothing of note in my logs. Any idea what could cause this? I never had this issue with the factory firmware. (when it worked :slight_smile: )

If you've selected a DFS channel (5 GHz band), the router can't start transmitting before it has done a 60s DFS survey (passively listening for potential DFS signals), only then it can enable the 5 GHz radio.

What you perceive as slowness is likely exactly this time span, when only the 2.4 GHz radio is up - which -by the very nature of it- is significantly slower and plagued by interference (which can also cause dropped packets) from your neighbours. Once the router has determined that it's allowed to use the selected DFS channel, your client probably notices the better 5 GHz signal and switches over.

1 Like

Interesting, but I don't think that is my issue here as I have the 2ghz and 5ghz radios set to different ESSIDs and it seems to occur on both equally. I guess it could just be interference/distance from the router, but it seems odd that it only seems to occur when I first connect my laptop to the network and works perfectly after a couple of minutes or so.

Maybe you can try the solution for my problem, not exactly what you are experiencing but maybe that could help (I assume you are running the latest 19.07.2):


Do all/most of your devices have both radios registered as auto-connect? Even not using the same ESSID, maybe they change to the better radio after awhile then.

Ensure that your testing device only has one radio auto-connect and do a site survey using Wifi Analyser.