R7500v2 Poor wifi range and slow down/up speeds

its pretty hard to permanently brick these units. But only take the risk if you can afford it..

forced it and got the same message

let me see if I can magnify the picture...

edit, with reading glasses I can see it, this should work but let me see if I suggested the right command...

bother... I forgot luci is a meta package and its dependencies are complex. try this (you may need to ctrl-shift-v to paste into the terminal):

opkg install --force-depends uhttpd libubox20191228 libblobmsg-json libjson-c4 libjson-script uhttpd-mod-ubus libubus20191227 luci-mod-admin-full luci-base lua liblua5.1.5 luci-lib-nixio luci-lib-ip libnl-tiny rpcd libuci20130104 libubus-lua luci-lib-jsonc liblucihttp-lua liblucihttp0 rpcd-mod-file rpcd-mod-luci cgi-io luci-mod-status libiwinfo20200105 libiwinfo-lua luci-mod-system kmod-ledtrig-default-on kmod-ledtrig-heartbeat kmod-ledtrig-netdev kmod-ledtrig-timer luci-mod-network rpcd-mod-iwinfo luci-theme-bootstrap luci-app-firewall luci-app-opkg luci-proto-ppp luci-proto-ipv6 rpcd-mod-rrdns

Okay take your time. Sorry I roped ya into this :joy:

no worries, see the edit above. It might be faster to TFTP flash a new factory snapshot image, ssh in, and then opkg update; opkg install luci should work.

EDIT or you could "scp" a new sysupgrade image to the r7500v2 and do a sysupgrade via the terminal... but I think that may be pushing it given you current comfort level...

Yeah I think im going to have to do it that way. The reason being is it is not letting me copy and paste anything in the terminal of Putty in Mint. It does on Windows. The only problem I am going to have with TFTP is if I can find one that has a GUI I will be okay. If I have to manually do everything via the command prompt I'm toast :joy:

I ran into this once. With imagebuilder I can avoid it and install luci before the image is installed. But that's more terminal work. There is no shame in using a "stable" build and giving yourself time to learn. A lot faster and less frustration that way.

Yeah, I'm going to flash a stable build if I can figure it out. I know how to do all this stuff in Windows its just with me just learning Linux finding programs similar to Windows is the problem. I am not good with all the terminal commands yet.

1 Like

It looks like all the TFTP programs I am finding on Mint are all configured by terminal. Therefore, I don't know if I am going to figure this one out. I don't have a Windows computer at the moment to do it from.

OMG! I got it to work :joy: :joy: :joy: thanks for your help very much appreciated.

not surprised... anyone willing to give openwrt/pfsense a shot has the initiative to figure this out. It does take time tho

good luck

Hahaha yes it does. One last question. If I want to say the heck with this nightly snapshot can I go back to the stable build by uploading it in the gui?

that's right.

you know, it has been so long since I used a stable build I can't remember. Try a stable sysupgrade image - the UI won't let you do something silly without a warning.

The r7800 is almost identical to the r7500v2. @hnyman maintains a "community build" for the r7800 and I believe I've seen that you can go back and forth between factory and sysupgrade images for these r7800 images (you can not use any r7800 image on the r7500v2 tho).

I find following just about any thread for the r7800 like this one helpful.

Good forum etiquette is to respect the 'OP's' scope for the thread (i.e. @hnyman generally requests that questions on his community forum thread only be relevant to his r7800 builds) but the other threads are a little more forgiving if your question is applicable to the other devices. @hnyman is really good and approachable so don't be too shy.

It looks like it is taking it. If it accepts it I'm done right? I don't have to flash the factory image after?

Factory image is only for TFTP flashing. sysupgrade for everything else.

1 Like

It is also good forum etiquette to mark your thread as "solved" once your done with it. It will help others that might need it later.

IMO, you solved it yourself in this post above.

Once it is marked solved the thread will "lock" to new posts 10 day's after the last post.

1 Like

Thanks again. Everything is working really good now. Marking it solved now :wink:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.