R7000 VLAN Tagging on WAN?

Hi folks, total newbie here...looking for some advice.

The problem I'm ultimately trying to solve is implementing better traffic management/prioritization for accessing the internet. I'm in the country and have a 25/1 25ms connection. My goal is to implement SQM and cake if possible as well as eliminating my ISP's junky router. I have a basic understanding of networking but I'm stumped on how to properly set up OpenWRT.

This is my current configuration:

LTE antenna ( -> ISP Router ( -> PC, ethernet (

This works totally fine. Then, I flashed my R7000 and tried to swap out the ISP Router.

LTE antenna ( -> R7000 OpenWRT ( -> PC (

My internet connection does not require PPPOE but does need the traffic on VLAN 35. So, I opened up the Switch menu, added a new VLAN as 35, and tagged the WAN. I couldn't connect to the internet. I tagged the CPU and the WAN to 35 and still couldn't connect. I didn't make any other changes to the default settings.

What am I missing? Any tips or resources you could point me to?

Thanks in advance

try cloning the WAN MAC address of the ISP router.

if the WAN MAC is not clearly labeled anywhere (eg bottom sticker or router's management interface), then you can just go get the MAC address of the LAN side of the ISP router and just -1 or +1 the last octet of the MAC address

1 Like