R64 autopart and uvol


Are autopart and uvol supported on the R64 version of OpenWrt? I keep receiving a message to install autopart when I attempt to run it despite it already being installed.



Can you provide the logs detailing the error?

Can you provide the output of

ubus call system board
1 Like
	"kernel": "5.10.161",
	"hostname": "OpenWrt",
	"system": "ARMv8 Processor rev 4",
	"model": "Bananapi BPI-R64",
	"board_name": "bananapi,bpi-r64",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03.3",
		"revision": "r20028-43d71ad93e",
		"target": "mediatek/mt7622",
		"description": "OpenWrt 22.03.3 r20028-43d71ad93e"

This is the only error I get:

root@OpenWrt:/tmp/log# autopart
-ash: autopart: not found
root@OpenWrt:/tmp/log# opkg install autopart
Package autopart (0.8-2) installed in root is up to date.

There is nothing in /var/log/

autopart isn't a binary, so you can't run it from a shell

The description for the package says

Automatically allocate and initialize a partition for LVM on first boot.

What is it you're trying to achieve?

I am seeing if there is an alternative way to resize /overlay/ since the R64 version of openwrt uses sqaushfs and does not seem to allow resizing nor does it allow extroot.

@d687r02j8g how do I use Autopart? The link you posted only show to make it.

When autopart is installed, the remaining space on the block device used for booting OpenWrt will be allocated to a LVM2 physical volume. You can then use uvol (another package you need to install and also the name of the CLI tool in this case) to create storage volumes.

Example to allocate all space to a single read-write filesystem:

freebytes=$(uvol free)
uvol create myvolume $freebytes rw

You can then change the mountpoint of that new volume by editing /etc/config/fstab.

1 Like

What is freebytes?

freebytes is a variable that will hold the amount of free space available in the lvm2 volume.

If you run the following, you'll be able to see how much space that is, also the volumes available.

freebytes=$(uvol free)
echo $freebytes
uvol list

Ah ok! Although when I run that command I receive

root@OpenWrt:~# freebytes=$(uvol free)
root@OpenWrt:~# echo $freebytes
No backend available. (tried: LVM UBI) To setup devices with block storage install 'autopart'.
root@OpenWrt:~# uvol list
No backend available. (tried: LVM UBI)
To setup devices with block storage install 'autopart'