R2S - snapshot vs packages

Hi, using R2S daily snapshot when I try to load some packages opkg reports that there are errors (I download the snapshot and sudenly i try to load the pachages I need).
How can i check when missing or incompatible packages will be replaced with working packages?

Cheers zWolf

1 Like

Hi, can you suggest me a lite image for R2S.
When package compatibility with will be restored snapshot images?

opkg install luci
opkg install openvpn-openssl luci-app-openvpn luci-app-commands luci-app-ttyd
opkg install luci-app-statistics
opkg install collectd-mod-cpu collectd-mod-interface collectd-mod-memory collectd-mod-ping collectd-mod-rrdtool collectd-mod-thermal

Thanks zWolf

The problem with using snapshot images is that it's a moving target. Most of the time the issue is a kernel version change which means any package that relies on a kernel module is now un-installable due to mismatching versions. Sometimes you run into issues because you've installed a snapshot version which includes changes that introduce new issues that have yet to be ironed out or reverted.

You could try using a newer version of the snapshot firmware (it builds daily), and then installing all the packages you require off the bat.

Since you're running an ARM SBC, I'd recommend building your own OpenWRT firmware image from master with the required packages already built in. If you ever run into a problem with package/repo mismatches, build a refreshed version with any new packages you need and just either plop in a different SD card with the new image or overwrite the old one and restore your backed up configuration.

As for normal support, you'll have to wait for the next major OpenWRT release:

The thread above has a lot of info you might find interesting. Also of use is the OpenWRT git repo to track development and potential fixes or changes:

1 Like

Thanks alot @ergamus.

zWolf