Questions about wireless

Both my device k3 and ea8500 have this problem :
When the channel is set to be greater than or equal to 52, the wireless is invalid


When the information is valid, the signal quality is poor


What is this question please.

Under "Advanced Settings", set your country. You are currently on "00", meaning "no country/world" which will only allow to use a subset of channels.

Also, your "current power" readout below reads 31 dBm. What you circled there is the signal to noise ratio.


I don't think it will show the signal when in master mode.
It may show the signal for each particular client.


In master mode it shows the signal of one client. If no client is connected N/A signal (--) is shown. If more than one client is connected it isn't definite which signal you will see.


After choosing another country, it will come out

However, why does the AC client not prefer radio1? Client and router put together (30cm)
I tested and turned off radio0, and the client could not connect to wifi at all

If you just offer two wifi networks with the same SSID, it is entirely up to the client device which one it chooses.

You can implement "band steering" to push devices on one network or the other, using 802.11v and/or DAWN. But that gets quite complicated very fast.

In your case, I don't think that is the actual reason, though:

That very much sounds like a problem with the client device. (From own experience, some devices -- especially older ones -- don't do well with higher channels. I tend to stay below the 100+ range.)

Thank you all
I think it is the reason of rom (maybe it is wireless driver or other, I don't know);
Exactly the same equipment, I used the 18.06 version of k3 before, and it is normal
(Built by a third party with openwrt source)

But now using this version is not normal (21.02)

The following is the 18.06 version about wireless settings

The following is the 18.06 version about wireless settings

The Phicomm K3 appears to be a Broadcom chipset. Broadcom wifi is not well supported by the Linux FOSS drivers available to OpenWrt. The original manufacturer build almost certainly used different drivers. The wifi hardware in Broadcom routers is for the most part not usable under the official builds of OpenWrt.

In any case it's very important to set the country to your actual country not leave it at "00". The AP's country code is sent to the client, which may alter client operation as well.