Hello,
I had sqm configured in the past but the latest release to my router (Netgear R7800) made me to make some mistakes and I end up hitting the router reset button (yes, I know now I could have used failsafe an etc, but I didn't).
So, now, when I reinstalled sqm packages sqm-scripts
and sqm-scripts-extra
I got a new config file which is different from the one I had before (I saved a backup of all files in /etc/config
and /.ssh
.
My home setup is the ISP ONT -> my router -> all other home devices
So, the original config is this:
config queue 'eth1'
option enabled '0'
option interface 'eth1'
option download '85000'
option upload '10000'
option qdisc 'cake'
option script 'piece_of_cake.qos'
option qdisc_advanced '0'
option ingress_ecn 'ECN'
option egress_ecn 'ECN'
option qdisc_really_really_advanced '0'
option itarget 'auto'
option etarget 'auto'
option linklayer 'none'
config queue 'wan'
option debug_logging '1'
option verbosity '5'
option squash_dscp '1'
option squash_ingress '1'
option ingress_ecn 'ECN'
option egress_ecn 'NOECN'
option interface 'eth0.12'
option download '180000'
option upload '90000'
option qdisc 'cake'
option script 'piece_of_cake.qos'
option qdisc_advanced '1'
option qdisc_really_really_advanced '0'
option itarget 'auto'
option etarget 'auto'
option enabled '1'
option linklayer 'ethernet'
option overhead '44'
Where the eth1
section was what came by default when I installed sqm packages and wan section was the only section I had before the update and before things went south!
When I restarted sqm with /etc/init.d/sqm restart
I got this:
~# /etc/init.d/sqm restart
SQM: Stopping SQM on eth0.12
SQM: Starting SQM script: piece_of_cake.qos on eth0.12, in: 180000 Kbps, out: 90000 Kbps
SQM: piece_of_cake.qos was started on eth0.12 successfully
So, it says there that SQM was restarted for eth0.12. But the config file refers no eth0.12. Is this fine?
This is part of my /etc/config/network
file:
config interface 'lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option device 'br-lan'
config interface 'wan'
option proto 'dhcp'
option peerdns '0'
list dns '1.1.1.1'
list dns '1.0.0.1'
option device 'eth0.12'
config interface 'wan6'
option proto 'dhcpv6'
option peerdns '0'
list dns '2606:4700:4700::1111'
list dns '2606:4700:4700::1001'
option device 'eth0.12'
Other question I have is if for an internet nominal speed of 200Mbit/s downstream and 100Mbit/s upstream, what values should I use? Or hos should I configure this?