Question about IPv6 prefix delegate

My ISP have IPv6 support recentlly. And they sent me a new modem (router).
But it's IPv6 prefix delegate function is seems buggy. (I'm not pretty sure)

It's clear to see that prefix is xxx/60 from their status page:

If I configure OpenWRT manually like this:

image

Everything works perfect!!

But if I let everthing unchanged/automatic (I think it should be). The IPv6 address can not assign to LAN:

The modem from ISP has super simple config page, I can do nothing with it.

Due to last few years of using their IPv4 service, It's better to assume this IPv6 address will change every few weeks...(They reset my connection during I'm playing a game, just because I hold the address too long, LMAO)

So is this really a bug on their modem, or I did something wrong?
If it's really a bug, is there any way to workaround, like "ignore the /N part of parent prefix"?

/etc/config/network

I've tried many other configure, but no luck.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd63:f3f5:016e::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.0.0'
        option ip6assign '60'
        option ifname 'extsw lan1 lan2 lan3 lan4 lan5 lan6 lan7'
        option delegate '0'
        option ip6hint '0'
        option ip6ifaceid '::1'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'
        option metric '1'
        list dns '127.0.0.1'
        option peerdns '0'

config interface 'wan2'
        option ifname 'lan8'
        option proto 'dhcp'
        option metric '2'
        option peerdns '0'

config interface 'wlan'
        option proto 'static'
        option type 'bridge'
        list ipaddr '10.0.254.1/24'
        option ip6assign '64'
        option ip6hint '0'
        option broadcast '10.0.255.255'
        list dns '10.0.254.1'
        option ifname 'radio1.network1'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'
        option peerdns '0'
        option reqprefix 'auto'
        option reqaddress 'try'
        list ip6prefix '2408:8207:78ad:33b0::/60'

What is exactly what you consider a bug?

Your ISP has assigned a /60 to you, so you can split it in sixteen /64 local networks. Looks fine to me.

How can I do the split?

My LAN interface and any computer will only have "ULA" address. (eg. fe80:xxxx)

(Only router's WAN interface get a global IPv6 address)

You have to replace your private wireguard key on the device since you posted it on the forum.

I'm surprised that the configuration works for you since you seem to use the same IPv6 prefix on lan and wan6. What's your DHCP settings, are you using IPv6 relays?

And the ISP router is broken if it delegates a prefix which it uses itself in whole or in part.

Oh I forgot the wg. I will change them.

I set anything in config/network: wan6: list ip6prefix 'XXXX::/60', my LAN will have IPv6 XXXX::1/60, automantic.

I tried relay/server/hybrid, but none of them works. I can not understand what is this mean, still googling.

The ISP router's IP is 2408:8206:78a0:1f79:4f4:c56e:c42:78ab and it has prefix 2408:8207:78ad:33b0::/60, it's different.
But I don't know which prefix is delegated from ISP router. Is it IPv6-PD on OpenWRT router interface status page?

On LAN:

        option ip6assign '64'
        option ip6class 'wan6 local'

Do not manually assign the prefix. Remove local if you do not want the ULA assigned to LAN.

1 Like

Have you tried to change that into 60? (under wan6)
And remove the ip6prefix.