Quectel EC200A-EU modem is not recognized

Hello, I need help please. I have a ZBT-link WE1326 with an MT7621 processor. I attached a Quectel EC200A-EU modem to it and it does not recognize it. I need to know what OpenWRT package I should add to the Firmware so that the modem is recognized. Thank you.

start by installing usbutils, and run lsusb, see if it's recognized by the OS.

or post cat /sys/kernel/debug/usb/devices.

if it's found, try https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_cdc

2 Likes

Hello, thanks for the answer. Well, according to your instructions and as I show you in the screenshots, the Quectel modem is not recognized.

Screenshot of the lsusb command.

[image]

image

Capture of the command cat /sys/kernel/debug/usb/devices.

2c7c:6005 is your modem.

Hi.

Can confirm that.
Just tested today same EC200A-EU over one zbt-826 T2.

root@OpenWrt:~# lsusb

Bus 001 Device 003: ID 2c7c:6005 Quectel Wireless Solutions Co., Ltd.

 root@OpenWrt:~# echo -e ATI | socat - /dev/ttyUSB2,crnl

Quectel

EC200A

Revision: EC200AEUHAR01A21M16

Working fine so far. Running for some test.

Hello. Thanks for answering. In the screenshot below are the team data. It is a ZBT-WE1326.

When you enter the lsusb command in the computer management console, it returns the following.

image

As you can see in the previous screenshot. There is nothing that refers to the Quectel EC200A-EU modem.

There is no need to post pictures.
You need to configure your router as shown in https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_cdc

Pay attention to:

it is also sometimes necessary to send a special “dial” command to the AT command port

1 Like

Hello, thanks for answering. Could you tell me where to find or how to proceed with the AT commands? Thank you.

On the same page:

It is recommended to install additional packages picocom kmod-usb-serial-option and consult AT Commands Guide for the given modem.

More about: sending AT commands from the router.

1 Like

Well. I don't know what that is that he mentions.

The equipment is a Quectel EC200A-EU modem for 3g/4g.

Shouldn't I say something like that?

image

Thankssss

Thanks for answering. The packages you mention are already installed.

I will review about AT commands.

Hi.

Just found a interesting approach to get you modem working with openwrt.

EC200

Just some modifications:

where is: 
echo  2c7c 6026 ff > /sys/bus/usb-serial/drivers/option1/new_id

modify to : 

echo  2c7c 6005 > /sys/bus/usb-serial/drivers/option1/new_id

same here:

if [[ $vid == 2c7c ]] && [[ $pid == 6026 ]]

to

if [[ $vid == 2c7c ]] && [[ $pid == 6005 ]]

And follow https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_cdc for network configuration.

Hello, thanks for the response, indeed 2c7c is from Quectel, so it is already being recognized by the ZBT-WE1326. However, when using LSusb in the console, the description "Quectel Wireless Solutions" does not appear.

After placing several packages, it no longer shows the "modem not recognized" message, now the error message is "Could not obtain the modem information"

Hi.
Your lte interface is wrong

It must BE like this.
Ec200x are ethernet "over" USB. So use DHCP protocol.

config interface 'wwan'
        option proto 'dhcp'
        option ifname 'usb0'
1 Like

NCM is a valid option in this case.
"Failed to get modem information" will be shown when the script is unable to read the manufacturer from the modem. Make sure you use option device '/dev/ttyUSB1' in the NCM interface configuration.

If NCM does not work you will need to take care of the connection setup or "dialling" and then use instructions for ECM mode from the wiki as it was advised in the very beginning.
The command that needs to be sent to the modem only once is AT+QNETDEVCTL=3,1

Hi.
I will test over ncm mode.
At this time, my zbt is running with a ec200a DHCP mode, without issue, and as expected.
Just used AT+QNETDEVCTL=1,1,1 for dialing.
Any improvment expected from DHCP mode to ncm ?

NCM is not the opposite to DHCP.
In NCM mode the connection script will "dial" on each connection attempt.
For pure ECM mode to work the modem itself will need to "dial" automatically.

1 Like

Using the dhcp variant with usb0, the 3g/4g interface could be connected. The interface is observed exchanging data but no internet connection is obtained, there is no place to place the APN. Some additional configuration may be necessary.

See https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_cdc#modem_preparation

When you configure the APN, check at the same time what will be shown in response to AT+QCFG=? and post the result as formatted text here please.

At the same time you have some Tx/Rx packets shown. It is worth checking if the modem itself is connected, so check with AT+CGPADDR and copy/paste the output here.
Assuming the modem has an IP address assigned, check if you can ping any IP address like 8.8.8.8 from the router.

Hi.
run this command:

root@OpenWrt:~# echo AT+CGDCONT? | socat - /dev/ttyUSB1,crnl

in my case, it will report this:

AT+CGDCONT?
+CGDCONT: 1,"IP","internet","0.0.0.0",0,0,0,0,0,0

"internet" is my isp apn, it was defined by running this command:

echo at+qicsgp=1,1,"internet" | socat - /dev/ttyUSB1,crnl