Qualcommax NSS Build

can you try the following?

In /etc/config/wireless

Replace the top 2 blocks in your config with:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option band '5g'
	option txpower '24'
	option country 'US'
	option channel '64'
	option htmode 'HE160'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'sae-mixed'
	option dtim_period '3'
	option max_inactivity '86400'
	option disassoc_low_ack '0'
	option ssid 'YOUR_SSID'
	option key 'YOUR_WIFI_PASSWORD'

Restart your 5G AP and retest.
wifi up radio0

EDIT: Country and channels for US. 80mhz is recommended to avoid interference for noisy environments. Will restrict speeds to 1200mbps vs 2400mbps but less prone to throughput issues.

Thank you for your fast reply!
Nothing changed unfortunately :frowning:
Still bad LAN Performance.
Also syslog doesn't show anything suspicious unfortunately.

Yes, but tagged VLANs need to be defined on the WAN port. The LAN port is not capable of handling tagged VLANs due to limitations in the DSA implementation.

example of my config
/etc/config/network

(snip)
config device
        option type '8021q'
        option ifname 'wan'
        option vid '20'
        option name 'wan.20'

config device
        option type 'bridge'
        option name 'br-wan-20'
        list ports 'wan.20'

config interface 'wan_20'
        option proto 'dhcp'
        option device 'br-wan-20'

/etc/config/wireless

(snip)
config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi'
        option channel 'auto'
        option channels '60 100 144'
        option band '5g'
        option cell_density '0'
        option country 'US'
        option htmode 'HE80'
        option txpower '23'
        option disabled '0'

config wifi-iface 'wifinet5'
        option device 'radio1'
        option mode 'ap'
        option ssid 'VAP20ax'
        option encryption 'psk2+ccmp'
        option ifname 'r1_ax.20'
        option network 'wan_20'
        option key 'mykey1234'

bridge

root@AX3600:~# brctl show
(snip)
bridge name     bridge id               STP enabled     interfaces
br-wan-20               7fff.88c397180e52       no              wan.20
                                                        r1_ax.20
(snip)
...

Sory, VLANs on the LAN port are now fully functional! It’s amazing—the mainline openwrt firmware couldn’t achieve this. Offloading is working perfectly! (comfirmed on lan1.20)

1 Like

what program is that? It looks like htop, but not

1 Like

the program is "btop".


Same problem on my builds.(iperf3 -c -R speed low / iperf3 servers on router / wired and wifi)
But I use @dimfish builds is no problem.
https://openwrt.admincomps.ru/nss-wifi/20240219/

The funny thing is that with dimfish's build (and also with AgustinLorenzo's) I have lots of transfer errors (maybe CRC?). Downloads/uploads either can't be completed (Chrome keeps reporting network errors), or when they are completed, the files are often corrupted.
Gigabit WAN from Vodafone (Germany). With the NSS firmware of my old R7800 for example I have none of these problems. Running smooth like butter for years.
But yeah, with dimfish and AgustinLorenzos build the LAN performance at least is as expected.

Yup, getting the same issue with bad LAN performance on the latest build

Device is Arcadyan AW1000

root@openmediavault:~# iperf3 -c 192.168.88.1
Connecting to host 192.168.88.1, port 5201
[  5] local 192.168.88.240 port 40520 connected to 192.168.88.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec   114 MBytes   958 Mbits/sec    0    356 KBytes       
[  5]   1.00-2.00   sec   112 MBytes   942 Mbits/sec    0    375 KBytes       
[  5]   2.00-3.00   sec   112 MBytes   937 Mbits/sec    0    390 KBytes       
[  5]   3.00-4.00   sec   113 MBytes   947 Mbits/sec    0    409 KBytes       
[  5]   4.00-5.00   sec   111 MBytes   934 Mbits/sec    0    409 KBytes       
[  5]   5.00-6.00   sec   112 MBytes   941 Mbits/sec    0    409 KBytes       
[  5]   6.00-7.00   sec   113 MBytes   946 Mbits/sec    0    427 KBytes       
[  5]   7.00-8.00   sec   112 MBytes   942 Mbits/sec    0    427 KBytes       
[  5]   8.00-9.00   sec   112 MBytes   938 Mbits/sec    0    427 KBytes       
[  5]   9.00-10.00  sec   113 MBytes   944 Mbits/sec    0    427 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  1.10 GBytes   943 Mbits/sec    0             sender
[  5]   0.00-10.00  sec  1.10 GBytes   941 Mbits/sec                  receiver

iperf Done.
root@openmediavault:~# iperf3 -c 192.168.88.1 -R
Connecting to host 192.168.88.1, port 5201
Reverse mode, remote host 192.168.88.1 is sending
[  5] local 192.168.88.240 port 60020 connected to 192.168.88.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  87.7 KBytes   718 Kbits/sec                  
[  5]   1.00-2.00   sec  1.02 MBytes  8.59 Mbits/sec                  
[  5]   2.00-3.00   sec   775 KBytes  6.35 Mbits/sec                  
[  5]   3.00-4.00   sec   609 KBytes  4.99 Mbits/sec                  
[  5]   4.00-5.00   sec  1021 KBytes  8.36 Mbits/sec                  
[  5]   5.00-6.00   sec   740 KBytes  6.06 Mbits/sec                  
[  5]   6.00-7.00   sec   742 KBytes  6.08 Mbits/sec                  
[  5]   7.00-8.00   sec   631 KBytes  5.17 Mbits/sec                  
[  5]   8.00-9.00   sec   638 KBytes  5.22 Mbits/sec                  
[  5]   9.00-10.00  sec   527 KBytes  4.32 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  6.88 MBytes  5.77 Mbits/sec  478             sender
[  5]   0.00-10.00  sec  6.66 MBytes  5.59 Mbits/sec                  receiver

iperf Done.
root@openmediavault:~#

no problem on my ax6
edit: forgot to mention, it's (latest commit - 2), I will try latest commit soon. But I believe it should work normally on ax6

LAN

$ iperf3 -c 10.0.0.1
Connecting to host 10.0.0.1, port 5201
[  5] local 10.0.0.10 port 49820 connected to 10.0.0.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec   113 MBytes   948 Mbits/sec    0    191 KBytes       
[  5]   1.00-2.00   sec   112 MBytes   941 Mbits/sec    0    194 KBytes       
[  5]   2.00-3.00   sec   112 MBytes   941 Mbits/sec    0    191 KBytes       
[  5]   3.00-4.00   sec   112 MBytes   941 Mbits/sec    0    194 KBytes       
[  5]   4.00-5.00   sec   112 MBytes   942 Mbits/sec    0   14.1 KBytes       
[  5]   5.00-6.00   sec  97.5 MBytes   818 Mbits/sec    0    191 KBytes       
[  5]   6.00-7.00   sec   112 MBytes   942 Mbits/sec    0    191 KBytes       
[  5]   7.00-8.00   sec   113 MBytes   945 Mbits/sec    0    191 KBytes       
[  5]   8.00-9.00   sec   112 MBytes   937 Mbits/sec    0    191 KBytes       
[  5]   9.00-10.00  sec   113 MBytes   946 Mbits/sec    0    191 KBytes       

[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  1.08 GBytes   930 Mbits/sec    0             sender
[  5]   0.00-10.00  sec  1.08 GBytes   929 Mbits/sec                  receiver

$ iperf3 -c 10.0.0.1 -R                                                                                                                                                                                                                   
Connecting to host 10.0.0.1, port 5201
Reverse mode, remote host 10.0.0.1 is sending
[  5] local 10.0.0.10 port 54874 connected to 10.0.0.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   1.00-2.00   sec   112 MBytes   942 Mbits/sec                  
[  5]   2.00-3.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   3.00-4.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   4.00-5.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   5.00-6.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   6.00-7.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   7.00-8.00   sec   112 MBytes   941 Mbits/sec                  
[  5]   8.00-9.00   sec   112 MBytes   942 Mbits/sec                  
[  5]   9.00-10.00  sec   112 MBytes   941 Mbits/sec                  

[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  1.10 GBytes   944 Mbits/sec    0             sender
[  5]   0.00-10.00  sec  1.10 GBytes   941 Mbits/sec                  receiver

WLAN

$ iperf3 -c 10.0.0.1                                                                                                                                                                                                                 
Connecting to host 10.0.0.1, port 5201
[  5] local 10.0.0.180 port 60342 connected to 10.0.0.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  77.1 MBytes   647 Mbits/sec    0   1.01 MBytes       
[  5]   1.00-2.00   sec  78.8 MBytes   661 Mbits/sec    0    864 KBytes       
[  5]   2.00-3.00   sec  80.0 MBytes   671 Mbits/sec    0   1.24 MBytes       
[  5]   3.00-4.00   sec  80.0 MBytes   671 Mbits/sec    0   1.09 MBytes       
[  5]   4.00-5.00   sec  77.5 MBytes   650 Mbits/sec    0   1.03 MBytes       
[  5]   5.00-6.00   sec  67.5 MBytes   566 Mbits/sec    0    888 KBytes       
[  5]   6.00-7.00   sec  77.5 MBytes   650 Mbits/sec    0    605 KBytes       
[  5]   7.00-8.00   sec  77.5 MBytes   650 Mbits/sec    0   1.09 MBytes       
[  5]   8.00-9.00   sec  80.0 MBytes   671 Mbits/sec    0   1.47 MBytes       
[  5]   9.00-10.00  sec  81.2 MBytes   682 Mbits/sec    0   1.19 MBytes       

[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   777 MBytes   652 Mbits/sec    0             sender
[  5]   0.00-10.01  sec   774 MBytes   649 Mbits/sec                  receiver
 

$ iperf3 -c 10.0.0.1 -R
Connecting to host 10.0.0.1, port 5201
Reverse mode, remote host 10.0.0.1 is sending
[  5] local 10.0.0.180 port 60900 connected to 10.0.0.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  46.2 MBytes   388 Mbits/sec                  
[  5]   1.00-2.00   sec  46.3 MBytes   389 Mbits/sec                  
[  5]   2.00-3.00   sec  46.0 MBytes   386 Mbits/sec                  
[  5]   3.00-4.00   sec  46.4 MBytes   389 Mbits/sec                  
[  5]   4.00-5.00   sec  45.4 MBytes   381 Mbits/sec                  
[  5]   5.00-6.00   sec  45.4 MBytes   381 Mbits/sec                  
[  5]   6.00-7.00   sec  45.9 MBytes   385 Mbits/sec                  
[  5]   7.00-8.00   sec  45.6 MBytes   382 Mbits/sec                  
[  5]   8.00-9.00   sec  45.7 MBytes   383 Mbits/sec                  
[  5]   9.00-10.00  sec  46.3 MBytes   388 Mbits/sec                  

[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   462 MBytes   387 Mbits/sec    0             sender
[  5]   0.00-10.00  sec   459 MBytes   385 Mbits/sec                  receiver

I also noticed that the disconnection issue when a torrent is active is back on the latest build.

You should configure the pbuf script for the nss wifi to prevent lockups on torrenting.

1 Like

Hi, guys! Referring to the ipq806x hardware acceleration manual, I made a qos script. It contains tbf shaper, prio classification, and three leaf qdiscs: pfifo, red and fq_codel. And you can copy it and change the dev to another name to apply it to other iFace.
Please note that it may be unstable, so I added a 30-second start-up delay. You can interrupt the sqm self-start within 30 seconds of startup to avoid loop restart and getting bricks.
Here is the link: raw.githubusercontent.com/michaelchen644/sqm-scripts/nss/src/nss_tbf.qos

4 Likes

Thanks! That worked really well, (but I do remember setting it up on the uci-defaults scripts but oh well) the issue with slow LAN is also gone:

rob@openmediavault:~/openwrt-ipq$ iperf3 -c 192.168.88.1
Connecting to host 192.168.88.1, port 5201
[  5] local 192.168.88.240 port 34590 connected to 192.168.88.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec   109 MBytes   914 Mbits/sec    0    296 KBytes       
[  5]   1.00-2.00   sec   109 MBytes   911 Mbits/sec    0    519 KBytes       
[  5]   2.00-3.00   sec   107 MBytes   899 Mbits/sec    0    519 KBytes       
[  5]   3.00-4.00   sec   107 MBytes   898 Mbits/sec    0    519 KBytes       
[  5]   4.00-5.00   sec   109 MBytes   914 Mbits/sec    0    519 KBytes       
[  5]   5.00-6.00   sec   107 MBytes   899 Mbits/sec    0    519 KBytes       
[  5]   6.00-7.00   sec   108 MBytes   906 Mbits/sec    0    519 KBytes       
[  5]   7.00-8.00   sec   107 MBytes   899 Mbits/sec    0    519 KBytes       
[  5]   8.00-9.00   sec   108 MBytes   905 Mbits/sec    0    519 KBytes       
[  5]   9.00-10.00  sec   106 MBytes   890 Mbits/sec    0    519 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  1.05 GBytes   903 Mbits/sec    0             sender
[  5]   0.00-10.00  sec  1.05 GBytes   901 Mbits/sec                  receiver

iperf Done.
rob@openmediavault:~/openwrt-ipq$ iperf3 -c 192.168.88.1 -R
Connecting to host 192.168.88.1, port 5201
Reverse mode, remote host 192.168.88.1 is sending
[  5] local 192.168.88.240 port 53772 connected to 192.168.88.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec   107 MBytes   896 Mbits/sec                  
[  5]   1.00-2.00   sec   108 MBytes   904 Mbits/sec                  
[  5]   2.00-3.00   sec   110 MBytes   920 Mbits/sec                  
[  5]   3.00-4.00   sec   109 MBytes   913 Mbits/sec                  
[  5]   4.00-5.00   sec   109 MBytes   913 Mbits/sec                  
[  5]   5.00-6.00   sec   109 MBytes   917 Mbits/sec                  
[  5]   6.00-7.00   sec   110 MBytes   925 Mbits/sec                  
[  5]   7.00-8.00   sec   109 MBytes   914 Mbits/sec                  
[  5]   8.00-9.00   sec   107 MBytes   901 Mbits/sec                  
[  5]   9.00-10.00  sec   110 MBytes   922 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  1.06 GBytes   914 Mbits/sec    0             sender
[  5]   0.00-10.00  sec  1.06 GBytes   912 Mbits/sec                  receiver

iperf Done.
rob@openmediavault:~/openwrt-ipq$

My log is full of these. Is this normal?

You have an AX3600? How is the memory holding up when setting the pbuf values?

It tends to eat away after about 24-48 hours on platforms with 512MB or less.

However, I think it may have also been related to an upstream issue in other parts of the kernel that looks to have been resolved? Can't say for sure.

When I first introduced the the pbuf script I had it autodetect the platform. You can always set it to a smaller amount if you start getting out of memory errors.

/etc/config/pbuf

config general opt
  option memory_profile 'off'
  # option memory_profile 'auto'
  # option memory_profile '1gb'
  # option memory_profile '512mb'
  # option memory_profile '256mb'

@Everyone,

If any of you are using the pbuf script, could I get a consensus for the values you're using?
1.) Are you letting it autodetect or setting a custom memory value for "memory_profile"?
2.) Have you experimented with editing the /etc/init.d/pbuf script and setting custom values for extra_pbuf_core0, n2h_high_water_core0, and n2h_wifi_pool_buf?

I wrote the pbuf script based off the values I found in QSDK's mac80211 init files.

Hi @qosmio

I currently have 2 AX3600 running with my latest build based in your code in which I have set the pbuf value to "auto" and at the moment no one has reported OOM to me nor have I suffered them on any of my 2 devices.

The first router right now has 118 MB free of RAM, this one has 2 days of uptime and the second has 145 MB free right now but it was restarted 1 hour ago due to a power outage.

In both the Wi-Fi configuration is WPA2/WPA3 mixed

Regards, Agustin

1 Like

Thank You!

Are your speeds on WiFi 6 clients also able to achieve 1200-1500 both up/down as well?

Hi @qosmio

My plan is 1GB D/U, for wifi I am getting 700/800 D/U, on channel 44 with channel width of 160 MHz.

Regards, Agustin

1 Like

Yes, I have an AX3600, I have set it to 1gb memory profile for now. Still observing if I were to get OOMs :slight_smile:

1 Like