QCA9880 can't connect to a client and create an AP simultaneously

I have a router which has QCA9880. It can connect to a client or be an AP without problems, but it can't connect to a client and be an AP at the same time.
The new AP created after the client won't work. It doesn't even show on my phone's wifi.
Is this a common issue?
test is the AP

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd16:e8ff:56e8::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option ifname 'eth1 eth1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 5 4 3'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 2 1'
        option vid '2'

config interface 'wwan'
        option proto 'dhcp'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface 'wifinet1'
        option ssid 'Vodafone-34688240'
        option device 'radio0'
        option mode 'sta'
        option key 'edtdhz38bp6ucp9'
        option encryption 'psk2'
        option network 'wwan'

config wifi-iface 'wifinet2'
        option encryption 'none'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ssid 'test'```

The STA generally has to connect before the AP comes on line. The Travelmate package addresses many of the operational complexities with AP and STA on the same radio.

I did connect the client first and then AP

Which router, which OpenWrt version? Just try to set channel of radio0 to 'auto' (it will be set/locked by the sta uplink anyway) and set htmode to 'VHT40' ... maybe that helps already.

Doesn't work. AP works only when there's no client, as soon as i add a client, the signal of AP goes to 0dBm.
I have an archer d7.

Set your country in the wifi-device blocks (both radios)

Try explicitly setting the channel number to the same one the AP you're connecting to uses.

Already tried, doesn't work.

No, you need to connect to the upstream AP; then the client SSID will be available.

In addition, both SSIDs must be on the same channel.

Tried doesn't work.
AP just won't work.

Is it a DFS channel? AP + client may not be supported on a DFS channel.

2 Likes

Yeap, you're right! My main modem frequency was set to AUTO, now that i set the fraquency to 40, everything works! Thank you.

Do you know anyway to keep the frequency Auto?

You were already told that auto cannot be set, as both the client and AP must be on the same (specified) channel. If you insisted on keeping the setting on Auto, that's likely why it didn't work.

Run some scans to identify a channel with no strong signals from neighbors, and set your main router to that one.

The channel of the main router will have to be also used by the repeater router. The radio can only operate on one channel.

1 Like

I know that the router can only operate on one channel, but I think it's possible to automatically change the AP channel whenever the STA changes.

My experience has been that the AP interface of a combined operation may not come up unless the channel is specifically set and matches the one in use.

3 Likes

On the OpenWrt AP config; or the upstream WWAN client STA config?

Otherwise, I'm thinking you want to somehow cause illegal interference to the upstream router by forcing it to change channels (not allowed topic discussion here).

I have a modem and a router and the modem is the upstream. I want to set the modem's frequency to auto. But when i set the modem's frequency to auto the router's AP stops working.

This is the problem that i want to solve.

There's no problem. I guess you don't understand WiFi channels.

Anyways, I just tested for this thread. Upon adding a WWAN SSID from the scan on the web GUI, it automatically populated the channel field.

I did the same thing! If I add STA and AP when the main modem's frequency is set to auto, AP won't work.
If I add STA and AP when the main modem's frequency is set to 40, for instance, AP works.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.