PXE boot option 66 not passed to client

Hi there. I'm having trouble with setting up a PXE-server. Hopefully someone can help me with this.

I want the OpenWRT dhcp-server ( to point a PXE-client to a boot file on a TFTP-server ( I tried setting both options 66 and 67 in the LuCI webinterface:

Now, when I boot the client, I get this:

PXE boot over IPv4
Station IP address is
Server IP address is
NBP filename is BOOTX64.EFI
NBP filesize is 0 bytes
PXE-E99 unexpected network error

Station IP & filename seem to be ok, but it doesn't get the correct TFTP-server address. It just gets the OpenWRT router IP.

Does anyone have an idea of what I'm doing wrong or how to fix it?

  • Who says?
  • Did you actually look at the DHCP requests and replies via a software e.g. Wireshark?
1 Like

Ok, that is an assumption. I’ll see if I can use wireshark as you suggested.

Edit: Looks like it does send the correct server host name specified in option 66. Next server IP is 77.3 though. I understood that the Next server IP should be the TFTP server?

Am I missing something here?

Btw, thanks for pointing me to Wireshark, great software!

Schermafbeelding 2020-12-05 om 11.25.15

No, it is the dhcp server address.

Is the filename on the boot server really all in upper case letters?

1 Like

dnsmasq / uci seems to not support boot sections anymore?... ( adding anyway )

anyway... if you lookup ssh... you can run this;

echo 'dhcp-boot=BOOTX64.EFI,,' >> /etc/dnsmasq.conf
/etc/init.d/dnsmasq restart

( efi / multi arches is tricky though... after basic testing you really need to either match via 'tag' or PXE-ARCH )


Great! Thank you very much.

I don't have a working PXE-boot yet, but it did download the NBP file, so that's progress!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.