Public Ipv6 issues

Hey everyone,
How do I correctly set up Ipv6 in openwrt? I have configured it, but only my dir 853 router gets an public Ipv6 address. The rest of the devices don't receive public ipv6, my dir 853 only provide a local lan IPv6. Is there any way to fix this issue


You've got no prefix delegated... Make sure that your provider supports it.

P.S. can you show us your /etc/config/network?

Looks like it was manually edited but anyway. Make it look like this...


config interface 'wan'
	option proto 'dhcp'
	option device 'wan'
	option ipv6 '1'

config interface 'wan6'
	option proto 'dhcpv6'
	option device '@wan'
	option reqaddress 'try'
	option reqprefix 'auto'

... and try capturing DHCPv6 messages coming to port 546 (UDP). You need to restart WAN6 interface for it to appear. Does it containt Prefix part?

In theory you should be able to run tcpdump -vvvv -i pppoe-wan udp port 546

Sample capture on my side looks like this. The last part with delegated prefix (IPV6_LONG_PREFIX):

IP6 (hlim 255, next-header UDP (17) payload length: 172) EDITED_ADDR.547 > EDITED_ADDR.546: [udp sum ok] dhcp6 reply (xid=dd8e49 (client-ID hwaddr type 1 EDITED_HW_ADDR) (server-ID hwaddr/time type 1 time 746747274 EDITED_HW_ADDR) (IA_NA IAID:1 T1:0 T2:0 (status-code NoAddrsAvail)) (IA_PD IAID:1 T1:86400 T2:138240 (IA_PD-prefix IPV6_LONG_PREFIX::/56 pltime:172800 vltime:259200) (status-code Success)) (DNS-server DNS_ADDR1 DNS_ADDR2))

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd40:5473:3302::/48'
option packet_steering '1'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option dns '1.1.1.1 1.0.0.1'

config interface 'wan'
option device 'wan'
option proto 'dhcp'
option ipv6 '1'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
option device '@wan'
option reqaddress 'try'
option reqprefix 'auto'

config interface 'tun0'
option proto 'none'
option device 'tun0'
option auto '0'

still it's not getting any public ipv6

Well, looks like you don't get prefix from your ISP...

But to be 100 percent sure I would run tcpdump as was said above (you need to install it first via opkg update && opkg install tcpdump).

1 Like

I think in that case you can configure ohpcd? into relay mode... which might work.

1 Like


Unable to read tcpdump file.Can please guide how to capture tcpdump correctly.

Is it what you get by running this command?

tcpdump -vvvv -i pppoe-wan udp port 546

Don't forget to restart your WAN6 interface when running it. Only in this case you will capture anything. Ctrl-C to stop capture.

after running tcpdump -vvvv -i pppoe-wan udp port 546
it say pppop-wan :no such device exists

Be creative. Change interface to match yours. It's wan.

tcpdump -vvvv -i wan6 udp port 546

No, it' not WAN6. It doesn't exist yet. It should be WAN.

Anyway, drop it. Proceed with step two, set up relay mode.

Congrats! Now we are sure, that your ISP doesn't provide you with prefix. Proceed with @moeller0 's advice.