Problems with VPN Address resolving

Hi, I was using the modem/router of my ISP, for that model everything was blocked so I ask for a bridge configuration and installed my TP-Link TL-WR1043ND v2 with OpenWRT.
Internet, LAN worked fine and then my girlfriend and I tried to user our VPN to work, i'm using OpenVPN, not sure which client she uses.

The problem is that now I cannot resolve private domains, the OS network configuration weren't changed and if I connect to the non bridged network (wifi of the router, it works).

We use WiFi as always, the modem has 1 port bridged that give us a public ip (that I'm using with OpenWRT) and another public address via WiFI (where I need to connect to correctly resolve VPN addresses).
IPV6 is disabled, aside of that I think I'm working with defaults for the DNS/DHCP configuration.

Any idea of what can be happening and if there is a way to solve it without changing the OS configuration?

Thank you!

Hi @Alexandros,
just to be sure I understood the context, I'm going to repeat your setup (if anything is wrong, let me know)

  1. ISP modem/router in bridge mode - OpenWRT (not running OpenVPN) - OpenVPN on your laptop
  2. When you don't run OpenVPN on your laptop, all is fine
  3. When you start OpenVPN on your laptop, DNS fails

I can think of three possibilities:

  1. You have modified your laptop DNS manually not to use DHCP and in there you have DNS servers that are not accessible through VPN (for example your ISP DNS servers) -> change to use DHCP or set up public DNS servers
  2. The VPN server you're connecting to is sending wrong DNS servers to your OpenVPN client -> you can disable DHCP and try to use public servers on your laptop
  3. Your OpenVPN client is set to ignore DNS servers from the server -> change that in OpenVPN config

One interesting test to run when connected to VPN and DNS is failing is to hit a couple of standard DNS servers and see if they get back to you.

nslookup # local setup should show the failure you're mentioning (and may give you more info as to what DNS server you're hitting)
nslookup # should resolve as you're hitting the Google DNS servers - unless your VPN network redirects those

Ultimately, if that VPN is provided by your workplace, talk to your IT guy in there about the issue as it seems to come down your VPN setup (not your OpenWRT box).

I hope that helps,