Problems upgrading to openwrt 21.02.0 on Belkin f9k1115v2


I have a belkin f9k1115v2 where I previously installed openwrt 18.06.

I have been trying to update openwrt to version 21.02.0 but when I tried it said that the upgrade file was not for f9k1115v2 but for f9k1115-v2. Thinking it was a mistake I forced the upgrade, but the router got bricked so I had to revert it back to the factory firmware.

Once in the factory firmware I tried again installing version 21.02.0 but when I try to install it from the factory firmware it finishes the install saying firmware installed, but stays with the factory firmware.

I tried again install the old firmware and was able to do it without any problems, but I still can't upgrade to version 21.02.0.

Can anyone help me with this problem?

flash the factory image from the recovery interface
off the top of my head
set your ip to
power on with the reset pressed down for a while the led change
login onto & upload factory image

I have finally been able to do the upgrade. After writing the original post I decided to try to install the factory image from the recovery interface and it worked. I was trying to avoid that since in the router page it was saying that you couldn't install 19.7 from the recovery interface, maybe it should be changed that part and add something specifying that this is the way to do the upgrade.

due to the ar71xx to ath79 things are not really the same as normal
but yes router page needs updating

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.