Problems replacing DD-WRT by Lede on Asus R7800

I purchased a used Netgear R7800 on which the previous owner had installed DD-WRT (Firmware: DD-WRT v3.0-r34015M kongat (12/09/17)). The device is working as expected and the router is accessible via

My objective is to replace DD-WRT by OpenWRT but so far have not been able to flash OpenWRT using TFTP recovery. To do so, I've primarily been trying out the instructions described in Netgear R7800 exploration (IPQ8065, QCA9984)

  1. Downloaded R7800-master-r6550-83e1fce17a-20180326-2140-sqfs-factory.img - the master build from @hnyman at Build for Netgear R7800
  2. PC (Windows 7): set network adapter to (
  3. Turn off the router
  4. Network cable plugged into LAN1
  5. Open cmd.exe
  6. While keeping the RESET button pressed, power up the router
  7. Wait till the POWER LED starts flashing ORANGE
  8. Run TFTP command (Cygwin): tftp -m binary -c put R7800-master-r6550-83e1fce17a-20180326-2140-sqfs-factory.img
  9. Release the RESET button

After a short while, the TFTP command comes back with "Transfer timed out." and the router has booted normally. Obviously have tried out a few variations on these instructions but no luck thus far.

Has anyone ever done this before, or any suggestions on how I could get DD-WRT replaced by OpenWRT?

Try by shortening the filename. E.g.: R7800.img

1 Like

This was something I had even tried just before putting up this new thread and didn't work at the time. Given your suggestion, decided to give it one more try and YES, this time it did flash OpenWRT onto the router, overwriting the existing DD-WRT.

Thanks a lot for the suggestion @muetzekoeln !

The reset button needs to be released after the power light starts blinking white and before the tftp transfer is started.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.