Problems : cannot connect to wifi and other issues

I have made an openWrt installation for a friend (yes... not the best bet for him, but I am the only option he has :sweat_smile: )

I have made an install with openWrt 19.07.7, and it all seems to work fine, however after a while (about 12 hours) he is unable to connect to wifi.

EDIT : I solved the problem.
Adding the explanation here for other readers (and removing my friend's config at his request, for privacy protection). I had forgotten to add the option instance argument to the dhcp section. This caused dnsmasq instances to try to cater for all dhcp domains. Since the dnsmasq instances also checked whether they were the only DHCP server on the subnetwork, this caused some dnsmasq instances to have an empty list of hosts and other to have the full list of hosts, even for other subnetworks (these issues could be seen in /tmp/hosts/dhcp.dnsmasq*).
Simply adding this option solved the wifi issue.

To my understanding eth0.1 is vlan 1 of eth0. I am astonished that an eth1 appears there.
Ah, see VLANs and CPU(eth0), CPU(eth1)

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.