Problem with wireguard peer handshake

Specify the same IP address which is configured in the peer's allowed IPs on the server side.

Excellent, thank you. that resolved the issue. I had added the address in the peer section, not in the main interface.

I currently have as an allowed ip, so everything is routed through the vpn. If I only wanted to send a subset of traffic via the vpn, presumably I can remove and just add a bunch of subnets to the setting in the network section? Or I can use something like the VPN Policy Routing package to do that?

1 Like

Both ways should be possible.
Note that allowed IPs can restrict access over the WG tunnel no matter the routing.
I.e. it won't work if you set up just policy routing with no allowed IPs.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.