Problem with luci-app-adblock

Hi, does anyone else except me have problems with latest luci-app-adblock? Itt doesnt show in "Services" submenu of webinterface. I have Netgear WNDR3700, extroot on USB HDD. I'm running OpenWrt 22.03.3, r20028-43d71ad93e and mentioned luci-app-adblock is luci-app-adblock - git-23.049.70484-d2c0e80 I tried without translation, with en translation but no luck.

Did you do any sysupgrades or opkg update install or luci-app-adblock lately?

Can you try in incognito if it displays or not?

And check also if the main adblock is also installed.

yes adblock is installed, in incognito it doesnt show up (Chrome latest/Win10). And yes I upgraded adblock & luci-app-adblock maybe 2-3days ago, I'm trying to keep my old router up-to date :slight_smile:

how old is your "USB HDD"

about a year-ssd (SATA->USB case) kingston 300GB - working w/o probs.

hm, usually doing opkg upgrade is not recommended as it can break things as discussed many times in the forum, but not base apps like adblock might be exception to this recommendation. so please check if adblock service is actually running: service adblock restart ; service adblock status. check syslog for any potential warnings. if everything is ok but still no luck after cleaning browser cache maybe should file an error report.