Problem with installing OpenWrt to Asus RT-N66U (Bricked my device?)

I am having some trouble with my first install of OpenWRT on my Asus RT-N66U.

I tried to upload the install file to my router via the update firmware function, but it complained about the uploaded file being a third party firmware, so I put the router in recovery mode and used Asus utility to force-flash the firmware on it, but I can´t connect to the web interface. I connected my computer via ethernet cable to the router and did an ip scan, and I noticed that the router´s hostname had changed to "OpenWrt.lan" and it had got an ip adress.
But when I try to connect to the router via the IP I had been given through my ip scan, It wouldn´t connect but I can ping the device.

I havn´t tried to flash Asus firmware back. Should I do that?

What are my next steps?
Have I bricked my router?

What's the IP you receive?

  • Can you SSH into the router?
  • Did you install a Snapshot by any chance?
  • Have you ever had OpenWrt installed before?

It doesn't seem so, as your device has an OpenWrt hostname now. It must have flashed successfully.

No, don´t think so.

No, I don´t think so. I downloaded this file.

Nope, just Asus own firmware.