Problem when following the official extroot configuration guide

Hi, I'm trying to make the installation storage for software larger on my OpenWrt Virtual Machine on Proxmox. The VM is installed with the default settings in Proxmox VE Helper-Script.

My Problem

After reading the official post on Extroot configuration and trying to find the problem, I managed to narrow it down to lacking a overlay partiton.

Here is the result from df -h

Filesystem                Size      Used Available Use% Mounted on
/dev/root               102.3M     23.6M     76.6M  24% /
tmpfs                   115.7M      1.0M    114.7M   1% /tmp
/dev/sda1                15.7M      5.5M      9.9M  36% /boot
/dev/sda1                15.7M      5.5M      9.9M  36% /boot
tmpfs                   512.0K         0    512.0K   0% /dev

Here is the result from block info

$ block info
/dev/sda1: UUID="..." LABEL="kernel" VERSION="1.0" MOUNT="/boot" TYPE="ext4"
/dev/sda2: UUID="..." LABEL="rootfs" VERSION="1.0" MOUNT="/" TYPE="ext4"

Where as in a video from youtube showed there should be a block device who's MOUNT is something like /overlay. So in the Configuring Extroot section, I got empty in the following command.

eval $(block info | grep -o -e 'MOUNT="\S*/overlay"')

What I tried

I added another disk to the VM and formatted it successufly with commands from the doc. As explained in the previous section, I thought I was just missing the /overlay partition, so I only changed the line which sets the variable MOUNT to the current path of overlay partition and runned the following commands

eval $(block info ${DEVICE} | grep -o -e 'UUID="\S*"')
uci -q delete fstab.extroot
uci set fstab.extroot="mount"
uci set fstab.extroot.uuid="${UUID}"
uci set"${MOUNT}"
uci commit fstab

I was expecting contents in /etc/fstab, but it's just emtpy.

I'm stucked now and don't what to do next.

Possible improvement on the doc

It would be great if the result/purpose of some important steps can be included in the doc, so beginners like me can verify if I've done it correctly.


I do not think that extroot is the best solution for a VM, where you can resize the partitions or add additional storage.


After reinstalling the OpenWrt VM as described in the question several times and following the guide, what I did turned out to be working. Somehow simply rebooting the VM did not work, it seems it worked after I rebooted the PVE entirely.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.