Problem using macchanger in a script

I have a GL.iNet GL-MT300N v2. I installed 19.07.1 and made the following script (rand-mac) in /etc/init.d to change the mac address of the wireless:

#!/bin/sh /etc/rc.common


start() {
        /sbin/ifconfig wlan0 down
        /usr/bin/macchanger -A wlan0
        /sbin/ifconfig wlan0 up

I then ran these commands:

chmod +x /etc/init.d/rand-mac
/etc/init.d/rand-mac enable

When I rebooted the router the mac address didn't change. I want the wireless to connect to an AP and have a cable connecting the LAN port to my laptop. What am I doing wrong?

*** edited to add ***

I forgot to mention that macchanger is installed