Problem to return stock firmware Archer C20 v5

Hello Guys.
I need your help with the Tp-link Archer C20 (ES) v5.

I have no problems installing the Openwrt firmare v 19.07.3 in my router. But the 5ghz network is working bad, too unstable for my taste.

I tried return to original firmware using the method follow:

dd if=recovery.bin of=tplink.bin skip=257 bs=512

mtd -e fimware -r write /tmp/tplink.bin fimware

The process presents no problemas, and the router boot up normally, the wifi network 2.4 and 5 working fine and the name of the wifi are the default (TP-LINK 854DE) and the ethernet network also fine, but the problem is that i cant access to the router interface hehehe. And the DHCP still assign me the .... Is like the Openwrt firmware still working.

I think that i doing wrong with the commands. The skip=257 bs= 512 is not the correct to my stock fimware.

If someone please can help with this..? Thanks for advance.

Welcome ImperatorSL. I own a different version of Archer C20. I have also suffered through 5 GHz malfunctions, but the latest release appears to be promising. You may consider upgrading to the latest version.

Good luck.

As you see that wifi name, it is stock firmware running. You may now need to reset the stock firmware to defaults using the reset button. Allow it to boot fully then hold down the button until the lights blink.

And what @Amat said, you were using an old version of OpenWrt that may not be the best experience.

1 Like

I tried the last version but the problem in 5ghz continues....

I tried to reset but the Openwrt still working on dhcp and the web interface is blocked hehehe.....

Thank you ImperatorSL. Please post images of your setup and 5 GHz failure(s) for 21.02.3.

Thank you ImperatorSL. Please post images of your setup and 5 GHz failure(s) for 21.02.3.>

No problem Amat. But im not interested in openwrt firmware anymore. The problem in 5ghz is just after a few seconds the wifi in that frecuency dissapear and so on.

My goal here with this post is seeking help for return to my stock firmware partially done hehehe

Thank you ImperatorSL. I suffered similar problem with Archer C20 v4 for an older release. We are a nonprofit community and your information will be invaluable to help debug any potential technical issues. This information may be helpful to others. Please consider this a generous donation to support this community.

Thank you for your time.

Best regards.