[problem solved but still need explanation] Need help with ports

hi everyone, i'm new there i've just installed lede and is fantastic, but i need some help for filesharing port opening

my lede router is connected to isp router, i cannot bridge it so i've used dmz, i've tryed to open the ports for emule on lede but does not work, i also tryed to set "accept" on every selection of firewall thinking this will disable firewall, but emule keep write i'm firewalled

i'm not a pro, and i don't have any other idea how to address this issue, i'm hoping you could help me

ps: i'm able to do things only with web gui

You do not need to open the ports, you need to forward them.

you are right i have forwarded under
From any host in wan
Via any router IP

and under "Forward to" there is my ip with the emule port

the same for udp, but does not working

i found the problem

my tcp and udp where a number like 4000, and was always worked fine on every router i had, now i've setup the number on 40000 and it worked, don't know why a 4k port is a problem but it seems that's the fix

edit: but with torrent i still have the problem that's wierd

that's weird, i've setted up the torrent port on the 40k range too and it works

there is a reason why with 4k or 50k (what i tryed and what i had with isp router) do not work on lede?
i'm curious

do you use the webinterface(1) or ssh(2) to configure your router?
(1) please post a screenshot of your port forwarding
(2) please post the content of the file /etc/config/firewall
the ip of your pc with the emule client and the emule port(-range) are helpful

i'm only able to use webinterface, there is any way to show the /etc/config/firewall without using ssh?
in the screenshot you can see also the ip of my pc with the emule client

i have to say now everything works fine, the weird things is if i change port tryed with 4000 and 50000 this config does not work

with the lede router i'm connected to isp router with dmz, this should be related to ports weird things? sound strange to me, but onestly all this situation sound strange

as i told i'm happy because everything works, but i'd like to know why with other ports i've tryed i had problem, and i'd like to ask you if you have the same issue with different port range, or it's just my issue