Problem setting up PPPoE 'Timeout waiting for PADO packets'

Hi everyone. I am trying to setup PPPoE with 1&1 fiber but all i get is a timeout:

daemon.warn pppd[23686]: Timeout waiting for PADO packets
daemon.err pppd[23686]: Unable to complete PPPoE Discovery

I tried sniffing with Wireshark what OpenWrt is doing but i cannot see any PPP activity whatsoever.

Everything works fine with the FritzBox router provided by the provider I collected all data and analyzed it in WireShark but OpenWrt does not come so far to initialize the configuration.

Model: netgear_r7800
Firmware: openwrt-23.05.0-ipq806x-generic-netgear_r7800-squashfs-sysupgrade fresh install

cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd7d:341b:ddf0::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'pppoe'
	option username '1und1/(E...d)ui...@online.de'
	option password '...'
	option ipv6 'auto'
	option ac 'esl...001'
	option host_uniq '04b...aaa'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '7'

This was one of my attempts with VLAN enabled, but there is no difference even if i disable VLAN completely.

You're missing the VLAN tagging (DTAG network) with VID 7.

  • drop the last four lines (VLAN3/ VID7)
  • change all (two) instances of eth0.2 with eth0.7
  • change the now last switch_vlan definition to say vlan 7 and vid 7
  • use ports 0t 5t
  • sanity check the rest of the file (I'm on my phone and might miss details)
1 Like

Is there any vlan needed there? Thanks to @slh there is!
Also the

Will spawn a virtual wan_6 so the wan6 you have will conflict. Change ipv6 to manual or 1 and keep the wan6 or delete wan6.

1 Like

OMG! made the suggested changes, removed wan6 and BAM! It works!

Thanks @slh & @trendy - this was super quick!

The final config for others:

cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd7d:341b:ddf0::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.7'
	option proto 'pppoe'
	option username '1und1/(E1..bd)ui...-...@online.de'
	option password '...'
	option ipv6 'auto'
	option ac 'es...01'
	option host_uniq '04...aa'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '0t 5t'
	option vid '7'
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.