Problem on D-Link DIR-645

Dear friends
Today I have installed LEDE on my D-Link DIR-645.
But i have a little problem: i don't find "Service" menu to configure options for installed programs.

version firmware: LEDE Reboot 17.01.1 r3316-7eb58cf109 /
LuCI lede-17.01 branch (git-17.100.70571-29fabe2)
kernel ver: 4.4.61

Any idea?

ok my router dead!
tx for your help.

Your router is dead or do you think that it's bricked ?

I'm not sure about the service menu you are talking about, I'm guessing that you mean install or remove packages. Using the CLI (Command Line Interface), you use opkg to do that. Under Luci (GUI), you have a "System=>Software" menu to do that.

You can have a look at available LEDE's packages there:

Tx DjiPi
yes, my modem it's bricked. But for me is impossible to connect in rescue mode to recovery!
I know Software menu, but don't find under luci were to configure software installed.

What is the hardware revision of your DIR-645? In the table of hardware, only A1 is supported.

Did you try the debricking instructions for DIR-645 Rev A1?

Thanks, but it's useless to waste a lot of time for a router without memory. Before it was damaged I tried to install openvpn and the memory was terminated. I'm looking for a more powerful new router compatible with lede firmware and openvpn server.


Even you don't seem to care about bricking this device, might I suggest you try to recover this one as a learning experience. If you get a bigger/better/mire expensive one and you don't flash it properly, you know how to recover without to much problems. 8mb flash and 64mb ram should be enough for OpenVPN. Maybe not the performance you want, but that also depends on your internet speed and a number of other factors.

1 Like

I want tu recovery but seems it's necessary diassemble modem to find the pins for serial port. But i don't have serial port on my computer and for me is very difficult without your help! Would you help me? Tx

According to the Wiki I linked for debricking DIR-645 Rev A1, you shouldn't have to open it. There is some kind of Web recovery I assume. Did you try the procedure?

To access, simply hold down the reset button while powering on the router. The WAN LED should blink. Set your computer with a static IP in the 192.168.0.x range, and open in a web browser. Recovery mode loads up within a few seconds, but doesn't respond to pings. If the power LED is blinking the above page should be accessible.

Use a TP-Link stock firmware freshly downloaded from their official site as the firmware file.

EDIT: Found evidence on DLink's forum: Make sure to use instead of the

For DIR-645 series routers, please try the following IP address:

1 Like

I have tried any of the procedures shown but it does not work. I tried with telnet, curl, http, but there is no recovery option. Thanks anyway but now is a useless box.

Do you have model Revision A1 ?

And do you still want to try to recover it the "hard way" then? You'll have to buy a USB serial TTL cable (that doesn't cost much) and disassemble the router; that's how you will get the serial port via USB.

There is a serial connection, if you look at this picture, you'll see JP1 (4 pins that points out of the board). That is if you have REV A1 of course.

Hi DjiPi I bought a GL-AR300M with LEDE firmware and preconfigured for OPENVPN.
Now I would like to set up my home network to take advantage of all the possibilities offered by the stroller.
Thank you

@pajeronda If you have questions about it, you really should start a new thread for that GL-AR300M. In that new topic, don't forget to explain in further details what you would like to do with your home network setup. I hope your new investment pays off!

EDIT: Rephrased to better reflect what I meant.

Thank you very much. I think so too. I just wanted to inform you about the purchase.

Thank you so much, but it helped me that no one, no where did not clarify about IP and it helped me a lot.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.