Problem installing openwrt on TPlink MR3420 v5

Hi there,
I tried installing Openwrt to TL-MR3420 V5 but it didn't install. i rebooted the device and it now shows up as TL-WR840N. I can no longer logon to the device. I'd appreciate some help here

this contradicts the below, since device model isn't displayed on the logon screen ...

When I first got the device, I was using it as a 3g router for internet access. I now want to use it as an access point, but it doesn't support access point mode. That's when I decided to load openwrt on it.. I confirmed the model and version before proceeding and downloaded the necessary files, followed the instructions of renaming it to tp_recovery.bin. placed it in the tftpd64 folder. Resetting the device, tftpd64 tries to load the file but it fails. When it resettled the IP address defaulted to, with the interface showing WR840N

whatever you flashed, it wasn't openwrt, where did you get the file ?

openwrt files are available at

I downloaded mine from

no dude, you didn't.
those links should be the same as the ones on the MR3420 wiki page.
unless you used one of the top two OEM links.

anyway, try the TFTP recovery again, hopefully it'll work, if you use the right image.

I downloaded from the link you provided and used it. it worked! thanks

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.