Problem flashing latest v13 patch set


#1

Continuing the discussion from TRENDnet AC2600 (TEW-827DRU v1.0R):

Hi,

Thanks for your great work !

Today I tried to flash my router with your latest build using the recovery mode.

Flashing appears to go well and I get a 'succesfull' message, but after reboot the original Trendnet firmware is still active.

Any idea what I might have done wrong ?

My current Trendnet firmware is v1.04 dated 12 september 2018
I have tried you patchset v13 luci

regards, louis


#2

Try flashing it again. There's no harm in trying it a few times.

I have occasionally noticed that flashing from the uboot recovery mode will fail if I don't hold the reset button down for the full four seconds. I don't fully understand why this is. Try holding it down for five seconds just to be sure.

If you have a console connected, you can get more information about what the system is doing, but you didn't mention having console access.

Let me know how it goes. Good luck.


#3

Just to be sure, you are using the "factory" image, and not the "sysupgrade" image, right?


#4

Thanks for your help and the quick reply.

Yes I flashed both the 0.01 and 0.1 Openwrt ‘factory’ images a few times.

I could try it a couple of times more.

I also read in another (Trendnet router) thread that they needed reset the router to factory defaults, then revert back to the initial factory image (using recovery) twice before trying to flash any custom firmware.
Does this make sence to you?


#5

Hi,

Just to be sure I flashed my router to the initial factory firmware and did a factory reset.

Then I tried flashing your v13 patch set with different browsers and after the 4th or 5th time (with Vivaldi browser) the router started up with OpenWrt.

Everything runs fine but I have one question/concern if I look at the log's I see hundreds of warning messages (see below). Is this a problem ?

Thu Aug 16 08:29:55 2018 kern.err kernel: [ 1816.452103] cpu cpu1: _set_opp_voltage: failed to set voltage (995000 995000 995000 mV): -22
Thu Aug 16 08:29:55 2018 kern.err kernel: [ 1816.452187] cpufreq: __target_index: Failed to change cpu frequency: -22
Thu Aug 16 08:30:05 2018 kern.err kernel: [ 1826.532148] cpu cpu1: _set_opp_voltage: failed to set voltage (995000 995000 995000 mV): -22
Thu Aug 16 08:30:05 2018 kern.err kernel: [ 1826.532249] cpufreq: __target_index: Failed to change cpu frequency: -22
Thu Aug 16 08:30:05 2018 kern.err kernel: [ 1826.552121] cpu cpu1: _set_opp_voltage: failed to set voltage (995000 995000 995000 mV): -22
Thu Aug 16 08:30:05 2018 kern.err kernel: [ 1826.552212] cpufreq: __target_index: Failed to change cpu frequency: -22
Thu Aug 16 08:30:05 2018 kern.err kernel: [ 1826.572131] cpu cpu1: _set_opp_voltage: failed to set voltage (995000 995000 995000 mV): -22
Thu Aug 16 08:30:05 2018 kern.err kernel: [ 1826.572222] cpufreq: __target_index: Failed to change cpu frequency: -22
Thu Aug 16 08:30:10 2018 kern.err kernel: [ 1831.518300] cpu cpu1: _set_opp_voltage: failed to set voltage (995000 995000 995000 mV): -22
Thu Aug 16 08:30:10 2018 kern.err kernel: [ 1831.518350] cpufreq: __target_index: Failed to change cpu frequency: -22
Thu Aug 16 08:30:10 2018 kern.err kernel: [ 1831.542149] cpu cpu1: _set_opp_voltage: failed to set voltage (995000 995000 995000 mV): -22
Thu Aug 16 08:30:10 2018 kern.err kernel: [ 1831.542199] cpufreq: __target_index: Failed to change cpu frequency: -22
Thu Aug 16 08:30:10 2018 kern.err kernel: [ 1831.562099] cpu cpu1: _set_opp_voltage: failed to set voltage (995000 995000 995000 mV): -22
Thu Aug 16 08:30:10 2018 kern.err kernel: [ 1831.562140] cpufreq: __target_index: Failed to change cpu frequency: -22


#6

I am certain that this isn't necessary and would not affect the way the recovery loader installs images. It's super low-level and doesn't even mount the main system image.

Just to be sure, I installed the OEM firmware to my test system here awhile ago, upgraded it to the new 1.04 image that was released last week on the 20th, and then installed OpenWRT. That went fine.

Anyway, it looks like you got it working.


#7

I have not seen errors like this, but they are related to the CPU scaling feature to save power. It's trying to lower the CPU voltage level to save power while the system is in low usage.

These are safe to ignore, though I'm concerned if you are really seeing hundreds of these.

Did you install any additional packages which might be causing the system to try and scale the CPU like this?


#8

I'm afraid I might have installed an additional package:

When I started Openwrt for the first time I saw (and stil see) the following message under system/software/available packages:

Package name Version Size (.ipk) Description
ath10k-firmware-q ca99x02018-04-19-71e50312-1 0 [Install]

I tried to install it, but apparently this has no effect because this message keeps returning.

In the installed packages tab it is listed as:

Package name Version
ath10k-firmware-qca99x0 2018-04-19-71e50312-1 [Remove]

I don't know if this is the package that was already there or if it is the one that I tried to install.

Do you think that I can safely remove it (in order to stop the log messages) ?


#9

I unistalled the package:

ath10k-firmware-q ca99x0

but this had no effect on the log messages.

Maybe I could have better waited for your feedback weather removing this was a good idea, because I have no idea what it actually does (or should do).
Anyways I do not have the option to install it again. Is this a problem ?


#10

Apparently this is what I have either installed/removed or removed:

"Standard ath10k firmware for QCA99x0 from QCA
This firmware conflicts with the CT 99×0 firmware, so select only
one."

Is this a key component that I have to reinstall or can I leave it the way it is ?


#11

A reboot proved it to be a critical component, I flashed your sysupgrade from within the Web GUI and this fixed it.

The log warnings (CPU voltage/frequency) however still remain


#12

This is the firmware for the 802.11/wifi radios. You don't want to remove that or you wifi will stop working. It is also not related to the error messages you were seeing.