Problem configuring VLANs on WRT32X

Hello,

I am trying to setup via ssh the VLANs for my ISP on a WRT32X and I read a lot of threads here but I'm not succeeding.

The VLANs my ISP has in bridge mode are:

Internet: id 6, priority 1
IPTV: id 2, priority 4

When I do reset the router and I do the welcome setup and enter the username and password for pppoe, internet works correctly but the TV does not, network file is automatically configured like this:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'pppoe'
        option disabled '0'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option disabled '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 5'

I tried a lot of configurations and I invested a lot of hours in order to add VLAN id 2 for IPTV but nothing worked and I don't know what else to do.

For more information

  • The TV decoder is on Port labelled with 4 (I think it is port 0?)
  • ISP told me that TV decoder needs VLAN 2 and internet connection too to connect external services like Netflix, I don't know if this is relevant like that the port where the decoder is has VLAN 2 + VLAN 6 or something like this, or if this is not possible and there is not solution for me.

Thank you in advance.

EDIT: for more information

I redone all the process and I'm going to detail it here for more information:

ONT

Do reset to ISP ONT and go to WAN setup, this is the default:

  • ID 3: VOIP
  • ID 2: IPTV
  • ID 6: Internet

Delete ID 2 and ID 6 WAN services

Add ID 2 bridge mode for IPTV:

vlan4

Is it good checking Allow as IGMP Multicast Source?

vlan5

Add ID 6 bridge mode for Internet:

vlan8

vlan9

LAN configuration:

Reboot ONT

WRT32X

Do reset and connect it to the configured ONT

Welcome setup, PPPoE

I leave the VLAN ID empty

If I put VLAN ID 6 it says that there is no connection:

Welcome setup done

Check internet connection setup

Connect via ssh and check /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option disabled '0'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option disabled '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 5'

You are not using VLAN 6 in that setup; if you can connect to the internet with that configuration, then your comment about VLAN 6 and 2 does not apply here.

Also, you have not configured any IPTV connection. But you do not mention any decoder, and you definitely do not need IPTV for Netflix.

Are you sure the ISP device is configured completely as a bridge?

1 Like

This is the ISP device configuration is a semibridge:

veip0.2 is VOIP and it is fine on the ISP device (I don't need it on the wrt32x).

About IPTV, I need to know what to put in the network file because I tried a lot of things with no luck, the image shows how the Welcome setup configures it by default when I set on Welcome setup the user/pass for PPPoE.

The decoder is on wrt32x port 4 (I think it is port 0) and it needs IPTV connection but it has Netflix installed and needs internet connection too.

Can you tell me what to put on the network file to configure the VLANs despite it is working internet connection like this? When I can I will check the configuration of the ISP device to check the bridge configuration.

Thank you.

I have edited the first post with all the process.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik

ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru;
root@tiruri:~# ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru;

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
241: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc prio state UP group default qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
root@tiruri:~# ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru;
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
241: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc prio state UP group default qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
242: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc prio state UNKNOWN group default qlen 3
    inet 81.37.230.140 peer 192.168.144.1/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via 192.168.144.1 dev pppoe-wan  proto static
192.168.1.0/24 dev br-lan  proto kernel  scope link  src 192.168.1.1
192.168.144.1 dev pppoe-wan  proto kernel  scope link  src 81.37.230.140
239.0.0.0/8 dev br-lan  scope link
local 81.37.230.140 dev pppoe-wan  table local  proto kernel  scope host  src 81.37.230.140
broadcast 127.0.0.0 dev lo  table local  proto kernel  scope link  src 127.0.0.1
local 127.0.0.0/8 dev lo  table local  proto kernel  scope host  src 127.0.0.1
local 127.0.0.1 dev lo  table local  proto kernel  scope host  src 127.0.0.1
broadcast 127.255.255.255 dev lo  table local  proto kernel  scope link  src 127.0.0.1
broadcast 192.168.1.0 dev br-lan  table local  proto kernel  scope link  src 192.168.1.1
local 192.168.1.1 dev br-lan  table local  proto kernel  scope host  src 192.168.1.1
broadcast 192.168.1.255 dev br-lan  table local  proto kernel  scope link  src 192.168.1.1
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 532
    inet6 fe80::6238:e0ff:fec9:b130/64 scope link
       valid_lft forever preferred_lft forever
9: wdev0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::6238:e0ff:fec9:b132/64 scope link
       valid_lft forever preferred_lft forever
10: wdev0ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::6238:e0ff:fec9:b132/64 scope link
       valid_lft forever preferred_lft forever
124: wdev1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::6238:e0ff:fec9:b131/64 scope link
       valid_lft forever preferred_lft forever
125: wdev1ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::6238:e0ff:fec9:b131/64 scope link
       valid_lft forever preferred_lft forever
241: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::6238:e0ff:fec9:b130/64 scope link
       valid_lft forever preferred_lft forever
fe80::/64 dev wdev0  proto kernel  metric 256  pref medium
fe80::/64 dev wdev1  proto kernel  metric 256  pref medium
fe80::/64 dev br-lan  proto kernel  metric 256  pref medium
fe80::/64 dev eth0  proto kernel  metric 256  pref medium
fe80::/64 dev wdev1ap0  proto kernel  metric 256  pref medium
fe80::/64 dev wdev0ap0  proto kernel  metric 256  pref medium
unreachable default dev lo  proto kernel  metric 4294967295  error -101 pref medium
local ::1 dev lo  table local  proto none  metric 0  pref medium
local fe80:: dev lo  table local  proto none  metric 0  pref medium
local fe80:: dev lo  table local  proto none  metric 0  pref medium
local fe80:: dev lo  table local  proto none  metric 0  pref medium
local fe80:: dev lo  table local  proto none  metric 0  pref medium
local fe80::6238:e0ff:fec9:b130 dev lo  table local  proto none  metric 0  pref medium
local fe80::6238:e0ff:fec9:b130 dev lo  table local  proto none  metric 0  pref medium
local fe80::6238:e0ff:fec9:b131 dev lo  table local  proto none  metric 0  pref medium
local fe80::6238:e0ff:fec9:b131 dev lo  table local  proto none  metric 0  pref medium
local fe80::6238:e0ff:fec9:b132 dev lo  table local  proto none  metric 0  pref medium
local fe80::6238:e0ff:fec9:b132 dev lo  table local  proto none  metric 0  pref medium
ff00::/8 dev wdev0  table local  metric 256  pref medium
ff00::/8 dev wdev1  table local  metric 256  pref medium
ff00::/8 dev br-lan  table local  metric 256  pref medium
ff00::/8 dev eth0  table local  metric 256  pref medium
ff00::/8 dev wdev1ap0  table local  metric 256  pref medium
ff00::/8 dev wdev0ap0  table local  metric 256  pref medium
unreachable default dev lo  proto kernel  metric 4294967295  error -101 pref medium
0:      from all lookup local
32766:  from all lookup main
4200000001:     from all iif lo failed_policy
4200000241:     from all iif br-lan failed_policy
4200000242:     from all iif pppoe-wan failed_policy

root@tiruri:~#

You ISP uses one VLAN for internet connection, one for IPTV, and another one for VoIP. According to the link you sent me privately (https://www.adslzone.net/foro/asus.164/es-posible-hacer-full-bridge-router-askey-movistar.475302/#post-3241882), the ONT is in a semi-bridge configuration, where all three VLANs are mirrored on the LAN port, untagged.

IMHO, that is a very weird way to do things, but I guess it is all that can be done with that ONT...

Notice how the guide you followed requires to change the LAN address on the OpenWrt router to 192.168.2.1, but yours is still configured on 192.168.1.1; please, do that change first. The next step is to add a route on the router. It looks like you do not have to fiddle with VLANs at all.

You are right, it is a weird way but it is all that can be done with that ONT.

I hadn't seen the steps you mentioned, I was following guides to configure de VLANs but you are right, I followed the steps in that guide (it's the linked next post) only adding the route on the router and now it is working fine internet and IPTV on every port of the router.

I don't know why are so much guides for this concrete ISP and ONT configuring VLANs when it is much easier this way.

Thank you very much for your help.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.