Hello
I have gone through the only two threads on PPSK setup (first one is How to setup vlans for dynamic PSK on router with 1 SSID?
The second one is reddit (https://www.reddit.com/r/openwrt/comments/1h63nel/openwrt_single_ssid_for_multiple_networks/)
I simply cannot make it work.
My setup is as follows -
No Vlan =1 (primary)
VLAN36, 37, 38
Sophos XG as gateway, with internal lan connected to trunk(General port on Cisco SG300). This internal lan has VLANS attached to it - which are also attached (created and VLAN joined on Cisco SG300 - 1UP, 36T 37T 38T).
Now, I want openwrt to have PPSk and based on PPSK, get the dhcp from the respective VLAN(which is on sophosXG - each VLAN has its own dhcp server)
The openwrt is connected again to SG300 on trunk (with 1UP, 36T 37T 38T)
Whatever configs I do (reddit link says I dont have to touch /etc/network - only /etc/wireless but forum one has bothe /etc/netwrk and wireless with vlans)
I am attaching below my /etc/network as well as /etc/wireless. Please find mistakes that I cannot see. I cannot get the clients to get DHCP. No packets are being tagged by openwrt to pass to SG300.
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdce:2f46:a643::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
option vlan_filtering '1'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan.1'
option proto 'dhcp'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'lan1:u*'
config bridge-vlan
option device 'br-lan'
option vlan '36'
list ports 'lan1:t'
config bridge-vlan
option device 'br-lan'
option vlan '37'
list ports 'lan1:t'
config bridge-vlan
option device 'br-lan'
option vlan '38'
list ports 'lan1:t'
config interface 'vlan36'
option proto 'none'
option device 'br-lan.36'
config interface 'vlan37'
option proto 'none'
option device 'br-lan.37'
config interface 'vlan38'
option proto 'none'
option device 'br-lan.38'
Below is wireless-
config wifi-device 'radio0'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
option band '2g'
option channel '1'
option htmode 'HE20'
option cell_density '0'
config wifi-device 'radio1'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
option band '5g'
option channel '36'
option htmode 'HE80'
option cell_density '0'
config wifi-iface 'wifinet0'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'test'
option encryption 'psk2+ccmp'
option key 'abcd1234'
config wifi-iface 'wifinet1'
option device 'radio0'
option mode 'ap'
option ssid 'test'
option encryption 'psk2+ccmp'
option key 'abcd1234'
option network 'lan'
config wifi-vlan
option name 'guest'
option network 'GUEST'
option vid '36'
config wifi-station
option key xxxxxxx
option vid '36'
config wifi-vlan
option name 'iot'
option network 'IOT'
option vid '38'
config wifi-station
option key 'xxxxx'
option vid '38'