PPPOE WAN speed on WRT1900AC

Just got a new internet connection with a new ISP. its Fiber connection 300mbit down and 300 upload.
Im running into what seem to be PPPOE slow WAN speed issue.
I came across this thread: Speeding up PPPoE

However doesnt look like anything came out of it. Im wondering if there is something i can do.
Perhaps a newer or a different PPOE package?
Seems like pppoe decryption or whatever only seems to make use of the single core of the router?

With 300 MBit/s PPPoE, the wrt1900ac shouldn't be a bottleneck, at least not for normal routing (without sqm, vpn or similarly complex services)

ok so to be more accurate. While my internet package is 300mbit, in reality the speed i get is 450mbits using the ISP's router. I have done tens of speed tests and that 450mbit speed is consistent. I believe this extra speed add on is to make up for the TV service that also runs on the same fiber channel etc. My previous cable company did the same thing. There my package was 120mbit but i would normally always get 150mbit.

Now, when im going via pppoe using the wrt1900ac the speed is maxing out at 350mbit. Sure, that is more than my actual package but i would still like to get that extra 100mbit that i am losing when compared to going through the ISP's router.

hopefully i can improve this somehow, otherwise i think my next step is to custom build a powerful router using pfsense. But i would hate to ditch openwrt as i am very comfortable with it and pfsense is a bit more complex

While doing a WAN to LAN speed test using speedtest.net, im running a "top" command on the wrt router and i can see the cpu peaking. That softirq process seems to be only taking advantage of the single core.

14 2 root RW 0 0% 49% [ksoftirqd/1]

so based on some more reading. Is it still true that hardware NAT is still not available in openwrt/LEDE?

I assume the answer to be moot given the device of interest, but have you tried flowoffload to see if any benefit is derived.

You’re saying that wrt1900ac is not of interest anymore?
What is this flowoffload?

Ok so I found the command for this flowoffload stuff. looks to be an IP tables command. After adding that in the router looks like I'm back in business. I'm getting my full speeds now.
still need to do some more testing cuz I'm not sure what this may have broken based on what I read on other threads.

No. The device is of interest, but iirc, HW NAT is not included in the list of offload units. I think flowoffload has been fairly well shaken out now.

So can this be built into my custom firmware somehow or is it not part of any module/packge in LEDE?
For now i'm using the following iptables command:
iptables -I FORWARD 1 -m conntrack --ctstate RELATED,ESTABLISHED -j FLOWOFFLOAD
Just wondering what that command does?

EDIT: Perhaps these should be included in the firmware?


All 4.14 images have it built by default. To turn it on, if using the GUI it can be turned on under the firewall page, or in /etc/config/firewall

config defaults
option flow_offloading '1'

Ah cool just saw it. It shows me two options there.
Hardware NAT offlload and Software offload. Do you know if hardware NAT is supported on the WRT1900AC ?

EDIT: Tried HW NAT, didnt do anything. Enabling software NAT brings the speed back up. So i think im ok for now, till i get a giga bit internet connection :slight_smile:

Off topic. Does anyone have experience with setting up wake on lan on pfsense.

If you know already that your question is offtopic, why don't you just open a new topic?

1 Like