PPPoE "unknown error (USER_REQUEST)"

Router: TP-Link TL-WR841N/ND v8
Kernel Version: 4.14.152
Build: latest master (18.06.5)

WAN interface (PPPoE) takes a lot of time to reconnect internet. Often gives me this error

daemon.info pppd[2767]: Plugin rp-pppoe.so loaded.
daemon.info pppd[2767]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
daemon.notice pppd[2767]: pppd 2.4.7 started by root, uid 0
daemon.warn pppd[2767]: Timeout waiting for PADO packets
daemon.err pppd[2767]: Unable to complete PPPoE Discovery
daemon.info pppd[2767]: Exit.

Sometimes luckily it connects other times it takes n number of times of re-connections.
Never happened this before on stock firmware or for any other routers.
More Info:
Switch "switch0" (AR934X built-in switch)===> only CPU (eth1) tagged default
Everything else is default.


Please post the whole network configuration in preformated text </> rather than screenshots
uci show network

uci show network output:

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth1.1'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.wan=interface
network.wan.ifname='eth0'
network.wan.proto='pppoe'
network.wan.username=*********
network.wan.password=*********
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='1 2 3 4 0t'

There doesn't seem to be any response from the ppp server.
Make sure that the modem is synchronized. If this is not the issue, ask your provider if you must set any service name or access concentrator.

2 Likes

But then how it connects even if it's default set to auto? Do you think I need to change VLAN port? Although this is regular PPPoE connection so I think default VLAN setting is fine.

I remember having this issue, my only solution was to create a configuration backup, do a factory reset, and right after it go straight into wan and re-create the pppoe connection, and test it. I also had to reflash the firmware to a previous build.

That depends on your ISP.

If they are not set, it uses the first discovered. If it doesn't discover any till PPP times out, you'll see this error. But it seems to me more possible to have an issue with the modem rather than that.

I remember having this issue, my only solution was to create a configuration backup, do a factory reset, and right after it go straight into wan and re-create the pppoe connection, and test it. I also had to reflash the firmware to a previous build.

WOW :dizzy_face:

I just asked my ISP. The technician told me that I don't have to set any VLAN (but mine is tagged by default?) Also no need to add 'Access Concentrator' but he sure did tell me to fill up 'Service Name' so I did the exact. Still same thing.
Further I added pppoe-discovery module to debug & got both 'Access Concentrator' & Service Name'. Filled up those & tested again. Same thing didn't help at all.
So anyone knows how to change pppoe discovery timeout? or how can I use previous version of PPPoE module in the latest build?

No it is not.

What is the time difference between these 2 log entries?

Furthermore, did you try any other OpenWrt version apart from 18.06.5? 18.06.4 for example.

PADO means it's waiting for a response from the ISP's equipment, if it intermittent it might be Packloss or an SNR issue i.e a fault on your line. I used to suffer from this a lot myself and it was simply because of a line fault was dropping the packets. If you can access your line stats from the modem would be handy.

How long is too long for you?

I am using pppoe, which often does not connect on the first attempt and I never considered that to be an issue. The ISP is likely load balancing your authentication requests and eventually you get to a good server. My line is showing attainable rate at 100/30 MBps for VDSL2, which is as clear line as it can be and it can still take more than one attempt to authenticate.

Wed Nov 20 15:06:59 2019 daemon.notice pppd[3558]: pppd 2.4.7 started by root, uid 0
Wed Nov 20 15:07:14 2019 daemon.warn pppd[3558]: Timeout waiting for PADO packets
Wed Nov 20 15:07:32 2019 daemon.notice pppd[4035]: pppd 2.4.7 started by root, uid 0
Wed Nov 20 15:07:47 2019 daemon.warn pppd[4035]: Timeout waiting for PADO packets
Wed Nov 20 15:11:14 2019 daemon.notice pppd[7162]: pppd 2.4.7 started by root, uid 0
Wed Nov 20 15:11:29 2019 daemon.warn pppd[7162]: Timeout waiting for PADO packets

On stock firmware, As I reboot the same router 1,2,3,..~30 seconds.
On OpenWrt it goes for hour(s). Even if I shut down router for 10 mins; it takes probably (varies from) 5 mins to 15 mins to connect.

I am using pppoe, which often does not connect on the first attempt and I never considered that to be an issue. The ISP is likely load balancing your authentication requests and eventually you get to a good server. My line is showing attainable rate at 100/30 MBps for VDSL2, which is as clear line as it can be and it can still take more than one attempt to authenticate.

It only has to do with OpenWrt :face_with_monocle:, Because I'm 100% certain other routers with stock firmwares have no issue connecting to my ISP.

I'd love to debug that but consider this,

  1. As I've said before, on stock firmware it works totally fine. Even on LEDE.
  2. If there was line fault, or constant packet loss etc. it would have occurred the same with stock & other routers too.

A picture showing the config page from the stock firmware could help here.

You mean this?
Stock Config
I took it from youtube to save time. These are the only settings I gotta do in stock firmware.

That's a very simple config page, I would expect it to have more options...

Solved. Turns out current PPPoE module was creating multiple PPPoE connections after one another without properly terminating the previous session and my ISP doesn't allow multiple PPPoE connections simultaneously. Hence it was taking time until ISP server resets my session ID>to connect internet.
So, yesterday I made a custom build firmware to add tcpdump-mini module. Flashed it filled in username & password for PPPoE connection. In PuTTY command propmt I ran this code
tcpdump -i eth0 -A pppoed
multiple times to gather PPPoE-discovery data until it connected to internet. Got 3 important fields from it,

  1. Access Concentrator
  2. Service Name
  3. Host-Uniq tag content (It is used by host to uniquely associate an Access Concentrator response (PADO or PADS) to a particular Host request (PADI or PADR))

Added those values in PPPoE-WAN interface along with
LCP echo failure threshold=2
LCP echo interval =5

Saved & Applied. Now re-connection is instant. If anyone has anything to add in this please do so. I'll keep testing for few more days then I'll mark this answer as a solution. :grinning:

2 Likes